logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: log4j 1.3alpha8 build
Date Tue, 31 Jan 2006 05:34:42 GMT
At 06:29 PM 1/30/2006 -0600, you wrote:
 >
 >On Jan 30, 2006, at 2:02 PM, Mark Womack wrote:
 >
 >> Of the 4 items mentioned, the jdk 1.3/1.4 issue is the biggest.  But
 >> it looks like the 1.4 dependencies have been resolved?  If so, then I
 >> can rebuild using 1.3, remove the breakiterator, and upgrade to Ant
 >> 1.6.5.  None of those will be hard to setup.
 >>

<snip>

 >
 >The -breakiterator flag has been removed and the handful of places
 >where breakiterator made a difference resolved in trunk as of rev
 >373024.

Why?

Have either of you looked at the Ant docs for the Javadoc task since 
Ant-1.6 came out (a long, long, time ago, I might add)?  It includes a 
"breakiterator" attribute which, as I understand it, takes effect under 
JDK1.4+.  I could be wrong, since I've never actually tested it under 
JDK1.3.1, but it seems to me that the smart way to implement the feature 
would be to ignore breakiterator="true" in cases where the JDK is less than 
1.4.  That way, the build is not tied to a particular JDK as 
additionalparam="-breakiterator" would do.  Please let me know if I'm 
wrong.  But if I'm not, it would make sense to use breakiterator="true"

Jake 


---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message