logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Reis <Luis.R...@netcabo.pt>
Subject RE: Log4J compiling requirements
Date Sun, 16 Feb 2003 01:10:07 GMT
Yes, I've sent a patch for LF5 to avoid a minor annoyance that happens
only if you are
running linux with dual displays.

My idea for Java NIO was to use the buffer API's to open/browse/filter
_____large_____ log files.

The patch that I've implemented doesn't compile on JDK < 1.4 and
defaults the window size to 800x600 on
failure. It there's any interest, I'll make run correctly on JDK 1.2.
But it will need more work to compile on any JDK
version >=1.2.

Either way, I'll have a look at JMS code in the build file.

Thanks,
Luis
 

On Sun, 2003-02-16 at 00:35, Mark Womack wrote:

    I guess my question is, are you thinking of adding/using some jdk 1.4
    specific code, Luis?  If yes, then that code should probably "optionally"
    compilable, similar to how the jms, etc code is in today's build script.
    
    As a side note, if I were to add some jdk 1.4 specific code to log4j, it
    would be a java.nio implementation of the socket related classes.  It would
    be nice if SocketAppender/SocketHubAppender/SocketNode could change their
    behavior based on what jdk is detected at runtime, but that would require
    jdk 1.4 to compile.
    
    -Mark
    
    > -----Original Message-----
    > From: Ceki Gülcü [mailto:ceki@qos.ch]
    > Sent: Saturday, February 15, 2003 4:12 PM
    > To: Log4J Developers List
    > Subject: Re: Log4J compiling requirements
    > 
    > 
    > 
    > Luis,
    > 
    > Compilation tricks are a headache to maintain. Unless there 
    > is a compelling 
    > reason, the code should compile with JDK 1.2 not only 1.4.
    > 
    > At 21:27 15.02.2003 +0000, you wrote:
    > >Hi,
    > >
    > >I know that the running requirement for Log4J 1.2 is JDK 
    > 1.1, although
    > >some parts of it only compile on JDK 1.2 (eg, LF5).
    > >
    > >Is it acceptable that minimum JDK for compilation is 1.4 although the
    > >code can still run on 1.1 or 1.2 ?
    > >
    > >Thanks,
    > >Luis
    > 
    > --
    > Ceki 
    > 
    > 
    > ---------------------------------------------------------------------
    > To unsubscribe, e-mail: log4j-dev-unsubscribe@jakarta.apache.org
    > For additional commands, e-mail: log4j-dev-help@jakarta.apache.org
    > 
    
    ---------------------------------------------------------------------
    To unsubscribe, e-mail: log4j-dev-unsubscribe@jakarta.apache.org
    For additional commands, e-mail: log4j-dev-help@jakarta.apache.org
    
    

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message