logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Hüsler <thomas.hues...@tri-edges.com>
Subject RE: File:Line info not showing when using SocketAppender/SimpleSocketServer
Date Wed, 13 Mar 2002 06:08:20 GMT
I had the same problem a couple of days ago... After a while I figured
out that this is just a problem with my dev environment....

When I am running the app in debug mode (or inside the dev environment
=> WebSphere Application Developer) it does not resolve the pattern
correctly, as soon as I use it outside of the dev environment (with the
JRE) it works....

I did not have the time to follow it up further... 

My guesses are, that there are problems to resolve it in debug mode or 
That it is a problem with none sun vms (I am using the IBM VM)


Cheers 
Tom

-----Original Message-----
From: Stuart Siegel [mailto:ssiegel95@yahoo.com] 
Sent: Tuesday, March 12, 2002 5:36 PM
To: log4j-cvs@jakarta.apache.org
Subject: File:Line info not showing when using
SocketAppender/SimpleSocketServer

I'm using a SocketAppender in (what I think) is the simplest possible
way.  My config file on the client side looks like:

#-------Client side configuration file-----------------
log4j.rootCategory=DEBUG, A1
log4j.appender.A1=org.apache.log4j.net.SocketAppender
log4j.appender.A1.Port=12345
log4j.appender.A1.RemoteHost=localhost
#------------------------------------------------------

I'm starting a SimpleSocketServer with the following config file as
the argument:

#-------------Server side config file----------- 
log4j.rootLogger=DEBUG, LOG_FILE
log4j.appender.LOG_FILE=org.apache.log4j.RollingFileAppender
log4j.appender.LOG_FILE.layout=org.apache.log4j.PatternLayout
log4j.appender.LOG_FILE.layout.ConversionPattern=%5p %d [%t] (%F:%L)
- %m%n
log4j.appender.LOG_FILE.File=clientLog
#--------------------------------------------------

Everything seems to be working pretty much as expected except that
the (%F:%L) formatting options in my conversion patterns shows as
"(?:?)" in the rolling file clientLog.  Using the same classes (I did
compile with debugging symbols) with a local appender produces the
correct file and line information. 

I know this is probably something trival but I could not find
anything mentioning it in the archives.

Thanks.

=====


__________________________________________________
Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!
http://mail.yahoo.com/

--
To unsubscribe, e-mail:
<mailto:log4j-cvs-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:log4j-cvs-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:log4j-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:log4j-dev-help@jakarta.apache.org>


Mime
View raw message