logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ceki Gülcü <c...@qos.ch>
Subject Re: 1.2 Backward Compatibility
Date Wed, 20 Feb 2002 00:28:45 GMT
Scott,

I have tested this just recently and did another test just to make sure. I 
have compiled the following code
with log4j 1.1.3

import org.apache.log4j.Category;
import org.apache.log4j.BasicConfigurator;

public class HelloWorld2 {
   static final Category cat = Category.getInstance("HelloWorld2");

   static public void main(String[] args) {
     BasicConfigurator.configure();
     cat.debug("Hello world.");
   }
}

and ran it with 1.2beta3 without  any problems. Bigger tests also ran 
without problems.
So I would appreciate if you could send me a test case in order to isolate 
the problem. Thanks, Ceki

At 10:24 20.02.2002 +1100, vFarquhar wrote:
>Ceki & others,
>
>I know that this came up a few weeks ago on the mailing list (with thread 
>"Interop with Log4j") - but I am having the same issue with the 1.2beta3.
>
>The runtime problem occurs when a library is compiled with 1.1.3 & run 
>with 1.2beta3.
>
>I haven't done a full test, so I could be wrong, but I wanted to save 
>myself some time if someone else has had the same problem.
>
>Thanks in advance,
>Scott
>--
>Scott Farquhar :: scott@atlassian.com


--
To unsubscribe, e-mail:   <mailto:log4j-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:log4j-dev-help@jakarta.apache.org>


Mime
View raw message