logging-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curt Arnold <carn...@apache.org>
Subject Re: [site] Error building site
Date Fri, 26 Mar 2010 05:11:00 GMT
The publish phase does an subversion commit which triggers en editor for the commit message.
 Better documented in the log4j, but the process requires that you have set the default subversion
editor to a blocking non-console editor using SVN_EDITOR or other means.  Like 

$ export SVN_EDITOR=xemacs
$ mvn site-deploy

I've added an echo to the console just before the svn commit to help.

There were also two files that were generated with inconsistent line ends.  I'm guessing that
is a bug that has crept into Doxia since the last time the script has been run.  I've worked
around it by adding a fixcrlf task to the build.xml file.

I've run the build and the web site can be previewed at:


Rerun the script if you need to and when you are ready, you can update the site by logging
on to people.apache.org and

$ cd /www/logging.apache.org
$ svn update

Running svn stat on that directory shows that all of log4php's content with the exception
of index.html was not checked out from the SVN.  Unless there has been a change, infrastructure
prefers site content to be checked out from the svn repo so they can rebuild the site without
having to rebuild to content.  Most of the complexity of site-deploy is to fool Maven to support
that approach, though there may have been improvements since I put our kludge together.

On Mar 25, 2010, at 2:23 AM, Christian Grobmeier wrote:

> thanks that helped for building - but now it simply stops after:
> "svn-commit.tmp"
>     [exec] "svn-commit.tmp" 25L, 601C
> No error message, no more activity. Before it prepared the site. Seems
> its not able to commit. Any ideas why?
>> Please check the PMC members in pom.xml.  Don't think I've added you.
> Yeah, added myself and Christian Hammers

View raw message