libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From to...@apache.org
Subject [libcloud] 01/02: Improve formatting.
Date Sun, 13 Dec 2020 13:29:13 GMT
This is an automated email from the ASF dual-hosted git repository.

tomaz pushed a commit to branch github_actions_take_2
in repository https://gitbox.apache.org/repos/asf/libcloud.git

commit ab80ac881f5ea0a084006ca08f81cdb8973468f5
Author: Tomaz Muraus <tomaz@tomaz.me>
AuthorDate: Sun Dec 13 14:26:33 2020 +0100

    Improve formatting.
---
 .github/workflows/main.yml | 110 +++++++++++++++++++++++++--------------------
 1 file changed, 61 insertions(+), 49 deletions(-)

diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index f2fdf0d..62a8127 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -45,22 +45,26 @@ jobs:
           - ubuntu-latest
 
     steps:
-    - uses: actions/checkout@master
-      with:
-        fetch-depth: 1
-    - name: Use Python ${{ matrix.python_version }}
-      uses: actions/setup-python@v2
-      with:
-        python-version: ${{ matrix.python_version }}
-    - name: Install OS / deb dependencies
-      run: |
-        sudo DEBIAN_FRONTEND=noninteractive apt-get install -yq gcc libvirt-dev
-    - name: Install Python Dependencies
-      run: |
-        pip install "tox==3.20.1"
-    - name: Run tox target
-      run: |
-        tox -e py${{ matrix.python_version }}
+      - uses: actions/checkout@master
+        with:
+          fetch-depth: 1
+
+      - name: Use Python ${{ matrix.python_version }}
+        uses: actions/setup-python@v2
+        with:
+          python-version: ${{ matrix.python_version }}
+
+      - name: Install OS / deb dependencies
+        run: |
+          sudo DEBIAN_FRONTEND=noninteractive apt-get install -yq gcc libvirt-dev
+
+      - name: Install Python Dependencies
+        run: |
+          pip install "tox==3.20.1"
+
+      - name: Run tox target
+        run: |
+          tox -e py${{ matrix.python_version }}
 
   code_coverage:
     name: Generate Code Coverage
@@ -74,25 +78,29 @@ jobs:
         python_version: [3.7]
 
     steps:
-    - uses: actions/checkout@master
-      with:
-        fetch-depth: 1
-    - name: Use Python ${{ matrix.python_version }}
-      uses: actions/setup-python@v2
-      with:
-        python-version: ${{ matrix.python_version }}
-    - name: Install OS / deb dependencies
-      run: |
-        sudo DEBIAN_FRONTEND=noninteractive apt-get install -yq graphviz gcc libvirt-dev
-    - name: Install Python Dependencies
-      run: |
-        pip install "tox==3.20.1"
-    - name: Run Checks
-      run: |
-        tox -e coverage-ci
+      - uses: actions/checkout@master
+        with:
+          fetch-depth: 1
+
+      - name: Use Python ${{ matrix.python_version }}
+        uses: actions/setup-python@v2
+        with:
+          python-version: ${{ matrix.python_version }}
+
+      - name: Install OS / deb dependencies
+        run: |
+          sudo DEBIAN_FRONTEND=noninteractive apt-get install -yq graphviz gcc libvirt-dev
+
+      - name: Install Python Dependencies
+        run: |
+          pip install "tox==3.20.1"
+
+      - name: Run Checks
+        run: |
+          tox -e coverage-ci
 
   lint_checks:
-    name: Run various lint checks
+    name: Run Various Lint and Other Checks
     runs-on: ubuntu-latest
 
     needs: pre_job
@@ -103,22 +111,26 @@ jobs:
         python_version: [3.7]
 
     steps:
-    - uses: actions/checkout@master
-      with:
-        fetch-depth: 1
-    - name: Use Python ${{ matrix.python_version }}
-      uses: actions/setup-python@v2
-      with:
-        python-version: ${{ matrix.python_version }}
-    - name: Install OS / deb dependencies
-      run: |
-        sudo DEBIAN_FRONTEND=noninteractive apt-get install -yq graphviz gcc libvirt-dev
-    - name: Install Python Dependencies
-      run: |
-        pip install "tox==3.20.1"
-    - name: Run Checks
-      run: |
-        tox -e checks,import-timings,lint,pylint
+      - uses: actions/checkout@master
+        with:
+          fetch-depth: 1
+
+      - name: Use Python ${{ matrix.python_version }}
+        uses: actions/setup-python@v2
+        with:
+          python-version: ${{ matrix.python_version }}
+
+      - name: Install OS / deb dependencies
+        run: |
+          sudo DEBIAN_FRONTEND=noninteractive apt-get install -yq graphviz gcc libvirt-dev
+
+      - name: Install Python Dependencies
+        run: |
+          pip install "tox==3.20.1"
+
+      - name: Run Checks
+        run: |
+          tox -e checks,import-timings,lint,pylint
 
   docs:
     name: Build and upload Documentation


Mime
View raw message