libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [libcloud] eamanu opened a new issue #1385: ImportError: Missing "OpenSSL" dependency during test
Date Fri, 13 Dec 2019 18:26:16 GMT
eamanu opened a new issue #1385: ImportError: Missing "OpenSSL" dependency during test
URL: https://github.com/apache/libcloud/issues/1385
 
 
   ## Summary
   
   If I run:
   
   ```
   pip install -r requirements-tests.txt
   python3 setup.py test
   ```
   
   I have the next error:
   
   ```
   ============================================================================================================
ERRORS =============================================================================================================
   __________________________________________________________________________________ ERROR
collecting libcloud/test/loadbalancer/test_nttcis.py ___________________________________________________________________________________
   ImportError while importing test module '/home/eamanu/dev/libcloud/libcloud/test/loadbalancer/test_nttcis.py'.
   Hint: make sure your test modules/packages have valid Python names.
   Traceback:
   libcloud/loadbalancer/drivers/nttcis.py:17: in <module>
       import OpenSSL
   E   ModuleNotFoundError: No module named 'OpenSSL'
   
   During handling of the above exception, another exception occurred:
   libcloud/test/loadbalancer/test_nttcis.py:25: in <module>
       from libcloud.loadbalancer.drivers.nttcis import NttCisLBDriver
   libcloud/loadbalancer/drivers/nttcis.py:20: in <module>
       raise ImportError('Missing "OpenSSL" dependency. You can install it '
   E   ImportError: Missing "OpenSSL" dependency. You can install it using pip - pip install
pyopenssl
   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Interrupted: 1 errors during collection !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
   ===================================================================================================
1 error in 134.47 seconds ===================================================================================================
   ```
   
   There are any reason for not add pyopenssl to requriments-tests.txt?
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message