libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alvaro (JIRA)" <j...@apache.org>
Subject [jira] [Created] (LIBCLOUD-1016) Libcloud should use sane OpenStack defaults for API versions
Date Thu, 27 Sep 2018 08:54:00 GMT
Alvaro created LIBCLOUD-1016:
--------------------------------

             Summary: Libcloud should use sane OpenStack defaults for API versions
                 Key: LIBCLOUD-1016
                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-1016
             Project: Libcloud
          Issue Type: Improvement
            Reporter: Alvaro


Libcloud sets the OpenStack API versions for each of the components to versions that are now
deprecated (like Nova 1.1, Keystone 2.0, etc), thus users have to force them almost always
(e.g. ex_force_auth_version='3.x'  for authenticating with recent Keystone versions).





--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message