libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahul Paigavan (JIRA)" <j...@apache.org>
Subject [jira] [Created] (LIBCLOUD-976) gce_test fails with multiple failures.
Date Thu, 25 Jan 2018 13:04:00 GMT
Rahul Paigavan created LIBCLOUD-976:
---------------------------------------

             Summary: gce_test fails with multiple failures.
                 Key: LIBCLOUD-976
                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-976
             Project: Libcloud
          Issue Type: Bug
          Components: Compute
         Environment: trunk branch of [https://github.com/apache/libcloud.git] repo.
            Reporter: Rahul Paigavan
         Attachments: test_gce.out

I have done a fix in

        libcloud/compute/drivers/gce.py

To test that, I have done some changes in

        libcloud/test/compute/test_gce.py

 

As per documentation, When I run below test command

PYTHONPATH=. python libcloud/test/compute/test_gce.py

I am getting multiple AttributeError failures for GCEMockHttp object.

As a setup part, I provided my secrets in libcloud/test/secrets.py.

    Modified GCE_PARAMS and GCE_KEYWORD_PARAMS.

 

I have tried to run the test without any of my changes on trunk branch.

I still get same issue. Please find attached output file for details.

 

Note: When I run any other test, It works fine.

$ PYTHONPATH=. python libcloud/test/compute/test_ecs.py
.........................................................
----------------------------------------------------------------------
Ran 57 tests in 0.791s

OK
$

 

This is a blocker for me to merge the PR without a test.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message