libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jmunhoz <...@git.apache.org>
Subject [GitHub] libcloud pull request: Add AWS4 support in the S3_RGW_OUTSCALE pro...
Date Mon, 04 Apr 2016 11:51:07 GMT
GitHub user jmunhoz opened a pull request:

    https://github.com/apache/libcloud/pull/736

    Add AWS4 support in the S3_RGW_OUTSCALE provider

    This patch adds AWS4 auth protocol support in the S3_RGW_OUTSCALE
    provider. It is needed to use AWS4 with the upcoming version of Ceph RGW
    (Jewel)
    
    Ceph Jewel will ship with AWS2 and AWS4 enabled by default.
    
    In the case of regions and signature binding, Ceph does not enforce any
    signature version per region. Every region supports AWS2 and AWS4. Ceph
    detects the signature version per request in order to authenticate
    properly.
    
    More information on the Ceph's AWS4 implementation:
    
    http://docs.ceph.com/docs/master/release-notes/#v10-1-0-jewel-release-candidate
    http://blogs.igalia.com/jmunhoz/blog/2016/03/01/aws-signature-version-4-goes-upstream-in-ceph.html

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/jmunhoz/libcloud s3-rgw-outscale-aws4

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/libcloud/pull/736.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #736
    
----
commit bc6512b346aa3f9db176969104034d841cea86f7
Author: Javier M. Mellid <jmunhoz@igalia.com>
Date:   2016-04-04T11:44:32Z

    Add AWS4 support in the S3_RGW_OUTSCALE provider
    
    This patch adds AWS4 auth protocol support in the S3_RGW_OUTSCALE
    provider. It is needed to use AWS4 with the upcoming version of Ceph RGW
    (Jewel)
    
    Ceph Jewel will ship with AWS2 and AWS4 enabled by default.
    
    In the case of regions and signature binding, Ceph does not enforce any
    signature version per region. Every region supports AWS2 and AWS4. Ceph
    detects the signature version per request in order to authenticate
    properly.
    
    More information on the Ceph's AWS4 implementation:
    
    http://docs.ceph.com/docs/master/release-notes/#v10-1-0-jewel-release-candidate
    http://blogs.igalia.com/jmunhoz/blog/2016/03/01/aws-signature-version-4-goes-upstream-in-ceph.html

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message