libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jeverling <...@git.apache.org>
Subject [GitHub] libcloud pull request: Replaced 'utf8' in ET.tostring with 'utf-8'...
Date Wed, 01 Jul 2015 15:51:06 GMT
GitHub user jeverling opened a pull request:

    https://github.com/apache/libcloud/pull/538

    Replaced 'utf8' in ET.tostring with 'utf-8', invalid XML (400) otherwise

    The XML that is generated by the Azure driver contains `encoding='utf8'`, which doesn't
work, the Azure API returns a 400 response. If this is changed to `utf-8`, it does work. Adjusting
the `encoding` argument passed to `ET.tostring` solved the 400 responses I was getting when
using `ex_create_cloud_service`.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/gundl/libcloud trunk

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/libcloud/pull/538.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #538
    
----
commit 8f03920c990b624dbb706682cb92e58fbba04db7
Author: Jesaja Everling <jesaja.everling@gl-systemhaus.de>
Date:   2015-07-01T15:44:37Z

    Replaced 'utf8' in ET.tostring with 'utf-8', invalid XML (400) otherwise

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message