libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dag Stenstad (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LIBCLOUD-603) Openstack Identity/Keystone v3 API not supported
Date Wed, 06 Aug 2014 18:16:12 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-603?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14087976#comment-14087976
] 

Dag Stenstad commented on LIBCLOUD-603:
---------------------------------------

Horrible force override:

Get a valid project-scoped token with curl or python-openstackclient:

TOKEN=`openstack token issue -f value -c id`

Openstack = get_driver(Provider.OPENSTACK)
Openstack('lol','lol',ex_force_auth_url='https://identity.api.zetta.io',ex_force_base_url='https://servers.api.zetta.io:8774/v1.1/<PROJECT_ID>',ex_force_auth_token='<TOKEN>>')]

It worked fine.


> Openstack Identity/Keystone v3 API not supported
> ------------------------------------------------
>
>                 Key: LIBCLOUD-603
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-603
>             Project: Libcloud
>          Issue Type: Improvement
>            Reporter: Dag Stenstad
>
> With the Identity v2.0 API marked as deprecated in Icehouse (alltho reverted after release),
cloud providers are starting to require using the v3 API to authenticate.
> This is needed to support domains, to achieve full multi-tenancy in public clouds.
> The v2.0 API seems to be scheduled for removal in the Kilo release next year.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message