libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dustin Spicuzza (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (LIBCLOUD-455) Openstack driver error in list_nodes() when image is null
Date Tue, 26 Aug 2014 22:17:58 GMT

     [ https://issues.apache.org/jira/browse/LIBCLOUD-455?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dustin Spicuzza resolved LIBCLOUD-455.
--------------------------------------

    Resolution: Fixed

> Openstack driver error in list_nodes() when image is null
> ---------------------------------------------------------
>
>                 Key: LIBCLOUD-455
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-455
>             Project: Libcloud
>          Issue Type: Bug
>    Affects Versions: 0.14.0-beta3
>            Reporter: Dustin Spicuzza
>
> Sometimes openstack nodes get into a state where they have no image associated with them
-- this only occurs when the node is in an error state and isn't able to be deleted. 
> When you call list_nodes() on a tenant that contains such a node, then it crashes because
it doesn't expect that the image doesn't have any data associated with it. The bug actually
occurs in _to_node().
> repr of api_node['image']: 
> A normal node: {u'id': u'9e77ab77-5564-432b-a3d4-6156af99ebd0', u'links': ….  }
> The error node: u''



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message