libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From to...@apache.org
Subject [2/8] git commit: Revert "Add argparse dependency for Python < 2.6 and >= 3.1 and <= 3.2."
Date Thu, 01 Aug 2013 12:41:13 GMT
Revert "Add argparse dependency for Python < 2.6 and >= 3.1 and <= 3.2."

This reverts commit a62b97a098441603832deb239307a8cd7cf53029.


Project: http://git-wip-us.apache.org/repos/asf/libcloud/repo
Commit: http://git-wip-us.apache.org/repos/asf/libcloud/commit/92f10fb7
Tree: http://git-wip-us.apache.org/repos/asf/libcloud/tree/92f10fb7
Diff: http://git-wip-us.apache.org/repos/asf/libcloud/diff/92f10fb7

Branch: refs/heads/trunk
Commit: 92f10fb7b538449f40449bb5080ee72c46eab525
Parents: 39e791c
Author: Tomaz Muraus <tomaz@tomaz.me>
Authored: Wed Jul 31 19:51:04 2013 +0200
Committer: Tomaz Muraus <tomaz@apache.org>
Committed: Thu Aug 1 14:30:03 2013 +0200

----------------------------------------------------------------------
 libcloud/utils/py3.py |  4 ----
 setup.py              | 11 ++---------
 2 files changed, 2 insertions(+), 13 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/libcloud/blob/92f10fb7/libcloud/utils/py3.py
----------------------------------------------------------------------
diff --git a/libcloud/utils/py3.py b/libcloud/utils/py3.py
index 1c44c27..206324e 100644
--- a/libcloud/utils/py3.py
+++ b/libcloud/utils/py3.py
@@ -28,7 +28,6 @@ PY2 = False
 PY25 = False
 PY27 = False
 PY3 = False
-PY31 = False
 PY32 = False
 
 if sys.version_info >= (2, 0) and sys.version_info < (3, 0):
@@ -43,9 +42,6 @@ if sys.version_info >= (2, 7) and sys.version_info <= (2, 8):
 if sys.version_info >= (3, 0):
     PY3 = True
 
-if sys.version_info >= (3, 1) and sys.version_info < (3, 2):
-    PY31 = True
-
 if sys.version_info >= (3, 2) and sys.version_info < (3, 3):
     PY32 = True
 

http://git-wip-us.apache.org/repos/asf/libcloud/blob/92f10fb7/setup.py
----------------------------------------------------------------------
diff --git a/setup.py b/setup.py
index 2bbeba7..fc82122 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ except ImportError:
 
 import libcloud.utils.misc
 from libcloud.utils.dist import get_packages, get_data_files
-from libcloud.utils.py3 import unittest2_required, PY31, PY32
+from libcloud.utils.py3 import unittest2_required
 
 libcloud.utils.misc.SHOW_DEPRECATION_WARNING = False
 
@@ -229,13 +229,6 @@ class CoverageCommand(Command):
         cov.save()
         cov.html_report()
 
-if pre_python26:
-    dependencies = ['ssl', 'simplejson', 'argparse']
-elif PY31 or PY32:
-    dependencies = ['argparse']
-else:
-    dependencies = []
-
 
 setup(
     name='apache-libcloud',
@@ -245,7 +238,7 @@ setup(
                 ' and documentation, please see http://libcloud.apache.org',
     author='Apache Software Foundation',
     author_email='dev@libcloud.apache.org',
-    requires=dependencies,
+    requires=([], ['ssl', 'simplejson'],)[pre_python26],
     packages=get_packages('libcloud'),
     package_dir={
         'libcloud': 'libcloud',


Mime
View raw message