lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Schöpf <rainer.scho...@gmx.net>
Subject Re: umlauts in DC elements
Date Fri, 26 Oct 2012 18:05:38 GMT
On Thu, 25 Oct 2012 at 13:58 +0200, Lars Geldner wrote:

 > we are using Lenya Apache Lenya 2.0.2 on Linux. All encoding configurations in sitemap.xmap
are set to UTF-8.
 > If we are putting german umlauts like ö, ä, ü in DC elements, e.g. in the 
 > description element, then we get problems after saving and displaying meta 
 > data page. All umlauts are displayed as "?". In addition, if we are searching 
 > (using Lucene) for strings that contains such umlauts, the appropriate pages 
 > are found. But the strings that we have searched for are displayed with a "?" 
 > too.

Are you running the supplied jetty or, e.g., tomcat?

I can reproduce the problem in Lenya 2.0.2 under Tomcat 5.5.  With Lenya 2.0.4 
and the supplied jetty server it works OK. 

This suggests that upgrading to 2.0.4 would solve the problem.

 > A second problem is that we cannot make changes on the DC elements that 
 > contain umlauts. A popup occurs saying "value can't be saved, concurrent 
 > change detected".

That is the same problem in a different disguise. When you make a change the 
browser sends both the old and new values of the element to lenya. It compares 
the stored value to the old value sent by the browser. Since they do not match, 
the error is signalled.

 Rainer

Mime
View raw message