lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Brüßler <m...@danielbruessler.de>
Subject Re: Lenya blank page, Cocoon works properly
Date Thu, 14 Oct 2010 12:57:02 GMT
Hello,

I tried it also with the .zip version of lenya 2.0.3 and the same
effect: just a blank page
for http://localhost:8888/

The trunk version I can try tomorrow.

----
There's no exception.

I now just deleted the logs folder
  src/webapp/WEB-INF/logs
and did a new build and set the rights
  chmod -R 774 ./

Here's the output of
  tail -f src/webapp/WEB-INF/logs/*
----------------------
==> src/webapp/WEB-INF/logs/2010_10_14.request.log <==
0:0:0:0:0:0:0:1 - - [14/Okt/2010:12:16:50 +0000] "GET / HTTP/1.1" 404 0

==> src/webapp/WEB-INF/logs/jetty-log4j.log <==
INFO main org.mortbay.util.Credential - Checking Resource aliases
INFO main org.mortbay.http.HttpServer - Statistics on = false for
org.mortbay.jetty.plus.Server@a01335
INFO main org.mortbay.http.HttpServer - Version Jetty/5.1.4
INFO main org.mortbay.jetty.servlet.XMLConfiguration - No
WEB-INF/web.xml in /d/REPOS/java/lenya203src/src/webapp. Serving files
and default/dynamic servlets only
INFO main org.mortbay.util.Container - Started
org.mortbay.jetty.servlet.WebApplicationHandler@6b7920
INFO main org.mortbay.util.Container - Started WebApplicationContext[/,/]
INFO main org.mortbay.http.SocketListener - Started SocketListener on
0.0.0.0:8888
INFO main org.mortbay.util.Container - Started
org.mortbay.jetty.plus.Server@a01335
----------------------

There is NO file in

  build/lenya/webapp/WEB-INF/logs/* 


Cheers!
Daniel

> On Thu, 2010-10-14 at 00:59 +0200, Daniel Brüßler wrote:
>   
>> Hello,
>>
>> every URL I try with lenya (using the embedded Jetty) shows just a blank
>> page.
>>     
>
> Is there an exception thrown?
>
> What does 
> tail -f build/lenya/webapp/WEB-INF/logs/* 
> returns when you request one of the pages?
>
> salu2
>
>   
>> http://localhost:8888/
>> http://localhost:8888/kldsjfkldjf
>> http://localhost:8888/default/
>> http://localhost:8888/lenya/
>> http://localhost:8888/lenya/index.html
>>
>> What can I uncomment or include in
>> $LENYA_HOME/src/webapp/global-sitemap.xmap
>> or
>> $LENYA_HOME/src/pubs/default/sitemap.xmap
>> to find the rendering problem ?
>>
>> Cheers!
>> Daniel
>>
>>     
>>> Hi,
>>>
>>> Do you deploy on tomcat (witch version?) or jetty (embedded ?) ?
>>>
>>> Witch url you try ?
>>>
>>> ++
>>>
>>> On 10/13/2010 05:38 PM, Daniel Brüßler wrote:
>>>   
>>>       
>>>> Hello,
>>>>
>>>> I started cocoon with
>>>> ./cocoon.sh
>>>> in $COCOON_HOME
>>>>
>>>> and it works properly. The changes I do in the sitemap.xmap and in the
>>>> xsl's and xml files work, I see the rendered xhtml in the browser. I
>>>> just do a
>>>> ./build.sh
>>>> in $COCOON_HOME
>>>>
>>>> Now the question is how can I test why lenya just renders a blank page?
>>>> Can I uncomment something from the lenya sitemap to find the
>>>> rendering-problem?
>>>>
>>>> (Lenya 2.0.3 on Ubuntu 10.04)
>>>>
>>>> Cheers!
>>>> Daniel
>>>>
>>>> :: TEL    +49 (0)911 - 815 90 30
>>>> :: Daniel Bruessler - Emilienstr. 10 - 90489 Nuernberg
>>>>     


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
For additional commands, e-mail: user-help@lenya.apache.org


Mime
View raw message