lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <scher...@gmail.com>
Subject Re: Lenya blank page, Cocoon works properly
Date Fri, 15 Oct 2010 07:39:38 GMT
On Thu, 2010-10-14 at 17:59 +0200, Daniel Brüßler wrote:
> Hello Thorsten,
> 
> shure, I did a build before running lenya :-)

Hmm, then I do not understand why you see the logs in the src tree.

> 
> ----
> 
> I've got the same lenya/lib jar-versions.
> 
> lenya-modules I don't have:
> org.apache.lenya.cms.languages.available
> org.apache.lenya.modules.atom
> org.apache.lenya.modules.batch
> org.apache.lenya.modules.batchworkflow
> org.apache.lenya.modules.blog
> org.apache.lenya.modules.importer
> org.apache.lenya.modules.linkrewriter
> org.apache.lenya.modules.rest
> org.apache.lenya.modules.scheduler
> org.apache.lenya.modules.simplesite
> org.apache.lenya.modules.tagcloud
> org.apache.lenya.modules.task
> 
> 

This modules can come from the contributions tree of our svn since the
tree was our company lenya where we use the defaultfiredocs pub.

> => In my eyes three have names, they might be required by the default
> publication.
> 
> Tomorrow I can install the trunk version, I think that three modules are in.

The modules are not the important part (at least shouldn't be). When I
looked at your tail result I saw that you have 
[14/Okt/2010:12:16:50 +0000] "GET / HTTP/1.1" 404 0

Means jetty response with a 404 (file not found). If you look at the
headers in your browser (with firebug you can see them) you should find
a server response with this headers. 

However reading between the lines of your mail seems that you are using
a custom pub and not the default pub, right?

salu2

> 
> Thanks for the tree command, I didn't know that. It's a nice tool.
> 
> Cheers!
> Daniel
> 
> >> Hello,
> >>
> >> I tried it also with the .zip version of lenya 2.0.3 and the same
> >> effect: just a blank page
> >> for http://localhost:8888/
> >>
> >> The trunk version I can try tomorrow.
> >>
> >> ----
> >> There's no exception.
> >>
> >> I now just deleted the logs folder
> >>   src/webapp/WEB-INF/logs
> >> and did a new build and set the rights
> >>   chmod -R 774 ./
> >>
> >> Here's the output of
> >>   tail -f src/webapp/WEB-INF/logs/*
> >> ----------------------
> >> ==> src/webapp/WEB-INF/logs/2010_10_14.request.log <==
> >> 0:0:0:0:0:0:0:1 - - [14/Okt/2010:12:16:50 +0000] "GET / HTTP/1.1" 404 0
> >>
> >> ==> src/webapp/WEB-INF/logs/jetty-log4j.log <==
> >> INFO main org.mortbay.util.Credential - Checking Resource aliases
> >> INFO main org.mortbay.http.HttpServer - Statistics on = false for
> >> org.mortbay.jetty.plus.Server@a01335
> >> INFO main org.mortbay.http.HttpServer - Version Jetty/5.1.4
> >> INFO main org.mortbay.jetty.servlet.XMLConfiguration - No
> >> WEB-INF/web.xml in /d/REPOS/java/lenya203src/src/webapp. Serving files
> >> and default/dynamic servlets only
> >> INFO main org.mortbay.util.Container - Started
> >> org.mortbay.jetty.servlet.WebApplicationHandler@6b7920
> >> INFO main org.mortbay.util.Container - Started WebApplicationContext[/,/]
> >> INFO main org.mortbay.http.SocketListener - Started SocketListener on
> >> 0.0.0.0:8888
> >> INFO main org.mortbay.util.Container - Started
> >> org.mortbay.jetty.plus.Server@a01335
> >> ----------------------
> >>
> >> There is NO file in
> >>
> >>   build/lenya/webapp/WEB-INF/logs/* 
> >>
> >>     
> >
> > hmm, there is no $LENYA_HOME/build? 
> >
> > If so did you do 
> > ./build.sh clean-all;./build.sh
> > before
> > ./lenya.sh
> > in $LENYA_HOME
> >
> > There should not be src/webapp/WEB-INF/logs/ since this should only
> > exist in the build folder. 
> >
> > Please confirm that you have the following basic tree structure 
> > thorsten@mcKenny:/opt/servers/lenya-codebusters/apache-lenya-2.0.3-src$
> > tree -L 3 build
> > build
> > `-- lenya
> >     |-- api
> >     |   `-- org
> >     |-- impl
> >     |   `-- org
> >     |-- java
> >     |   `-- pubs
> >     |-- lib
> >     |   |-- org.apache.forrest.plugin.output.inputModule-r431162.jar
> >     |   |-- xindice-1.1.jar
> >     |   |-- xmldb-common-20030701.jar
> >     |   `-- xmldb-xupdate-20040205.jar
> >     |-- modules
> >     |   |-- org.apache.lenya.cms.languages.available
> >     |   |-- org.apache.lenya.modules.ac
> >     |   |-- org.apache.lenya.modules.acusecases
> >     |   |-- org.apache.lenya.modules.administration
> >     |   |-- org.apache.lenya.modules.atom
> >     |   |-- org.apache.lenya.modules.batch
> >     |   |-- org.apache.lenya.modules.batchworkflow
> >     |   |-- org.apache.lenya.modules.blog
> >     |   |-- org.apache.lenya.modules.cache
> >     |   |-- org.apache.lenya.modules.cforms
> >     |   |-- org.apache.lenya.modules.collection
> >     |   |-- org.apache.lenya.modules.contactform
> >     |   |-- org.apache.lenya.modules.editors
> >     |   |-- org.apache.lenya.modules.export
> >     |   |-- org.apache.lenya.modules.fckeditor
> >     |   |-- org.apache.lenya.modules.importer
> >     |   |-- org.apache.lenya.modules.janitor
> >     |   |-- org.apache.lenya.modules.ldap
> >     |   |-- org.apache.lenya.modules.lenyadoc
> >     |   |-- org.apache.lenya.modules.linkcheck
> >     |   |-- org.apache.lenya.modules.linking
> >     |   |-- org.apache.lenya.modules.linkrewriter
> >     |   |-- org.apache.lenya.modules.lucene
> >     |   |-- org.apache.lenya.modules.menubar
> >     |   |-- org.apache.lenya.modules.metadata
> >     |   |-- org.apache.lenya.modules.monitoring
> >     |   |-- org.apache.lenya.modules.navigation
> >     |   |-- org.apache.lenya.modules.news
> >     |   |-- org.apache.lenya.modules.notification
> >     |   |-- org.apache.lenya.modules.observation
> >     |   |-- org.apache.lenya.modules.opendocument
> >     |   |-- org.apache.lenya.modules.properties
> >     |   |-- org.apache.lenya.modules.reporter
> >     |   |-- org.apache.lenya.modules.resource
> >     |   |-- org.apache.lenya.modules.rest
> >     |   |-- org.apache.lenya.modules.scheduler
> >     |   |-- org.apache.lenya.modules.simplesite
> >     |   |-- org.apache.lenya.modules.sitemanagement
> >     |   |-- org.apache.lenya.modules.sitetree
> >     |   |-- org.apache.lenya.modules.sourcerepository
> >     |   |-- org.apache.lenya.modules.svg
> >     |   |-- org.apache.lenya.modules.tagcloud
> >     |   |-- org.apache.lenya.modules.task
> >     |   |-- org.apache.lenya.modules.templating
> >     |   |-- org.apache.lenya.modules.tinymce
> >     |   |-- org.apache.lenya.modules.usecase
> >     |   |-- org.apache.lenya.modules.usecasedocument
> >     |   |-- org.apache.lenya.modules.webdav
> >     |   `-- org.apache.lenya.modules.workflow
> >     |-- pubs
> >     |   `-- org
> >     |-- temp
> >     |   |-- modules-build.xml
> >     |   |-- modules-config.xml
> >     |   |-- modules.xconf
> >     |   |-- modules.xml
> >     |   `-- patch
> >     `-- webapp
> >         |-- error.xmap
> >         |-- global-sitemap.xmap
> >         |-- jcr-repository
> >         |-- lenya
> >         |-- lenya.properties.xml
> >         |-- readme.xml
> >         |-- sitemap.xmap
> >         `-- WEB-INF
> >
> > 66 directories, 13 files
> >
> > salu2
> >   
> >> Cheers!
> >> Daniel
> >>
> >>     
> >>> On Thu, 2010-10-14 at 00:59 +0200, Daniel Brüßler wrote:
> >>>   
> >>>       
> >>>> Hello,
> >>>>
> >>>> every URL I try with lenya (using the embedded Jetty) shows just a blank
> >>>> page.
> >>>>     
> >>>>         
> >>> Is there an exception thrown?
> >>>
> >>> What does 
> >>> tail -f build/lenya/webapp/WEB-INF/logs/* 
> >>> returns when you request one of the pages?
> >>>
> >>> salu2
> >>>
> >>>   
> >>>       
> >>>> http://localhost:8888/
> >>>> http://localhost:8888/kldsjfkldjf
> >>>> http://localhost:8888/default/
> >>>> http://localhost:8888/lenya/
> >>>> http://localhost:8888/lenya/index.html
> >>>>
> >>>> What can I uncomment or include in
> >>>> $LENYA_HOME/src/webapp/global-sitemap.xmap
> >>>> or
> >>>> $LENYA_HOME/src/pubs/default/sitemap.xmap
> >>>> to find the rendering problem ?
> >>>>
> >>>> Cheers!
> >>>> Daniel
> >>>>
> >>>>     
> >>>>         
> >>>>> Hi,
> >>>>>
> >>>>> Do you deploy on tomcat (witch version?) or jetty (embedded ?) ?
> >>>>>
> >>>>> Witch url you try ?
> >>>>>
> >>>>> ++
> >>>>>
> >>>>> On 10/13/2010 05:38 PM, Daniel Brüßler wrote:
> >>>>>   
> >>>>>       
> >>>>>           
> >>>>>> Hello,
> >>>>>>
> >>>>>> I started cocoon with
> >>>>>> ./cocoon.sh
> >>>>>> in $COCOON_HOME
> >>>>>>
> >>>>>> and it works properly. The changes I do in the sitemap.xmap
and in the
> >>>>>> xsl's and xml files work, I see the rendered xhtml in the browser.
I
> >>>>>> just do a
> >>>>>> ./build.sh
> >>>>>> in $COCOON_HOME
> >>>>>>
> >>>>>> Now the question is how can I test why lenya just renders a
blank page?
> >>>>>> Can I uncomment something from the lenya sitemap to find the
> >>>>>> rendering-problem?
> >>>>>>
> >>>>>> (Lenya 2.0.3 on Ubuntu 10.04)
> >>>>>>
> >>>>>> Cheers!
> >>>>>> Daniel
> >>>>>>
> >>>>>> :: TEL    +49 (0)911 - 815 90 30
> >>>>>> :: Daniel Bruessler - Emilienstr. 10 - 90489 Nuernberg
> >>>>>>     
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
> For additional commands, e-mail: user-help@lenya.apache.org
> 

-- 
Thorsten Scherler <thorsten.at.apache.org>
codeBusters S.L. - web based systems
<consulting, training and solutions>
http://www.codebusters.es/


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
For additional commands, e-mail: user-help@lenya.apache.org


Mime
View raw message