lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hongbing cheng <ifra...@gmail.com>
Subject Re: Insert image problem
Date Mon, 13 Apr 2009 05:01:45 GMT
Hi Michael Keller,

   The followings are my opinion (Lenya 2.0.2):


   1.  You can use FireFox 2 to adapt BXE. I have tested BXE in FireFox
   2.0.0.20, all the functions are ok except previewing the image you want to
   insert.
   2. The image function of the Kupu has bug, but not yours that you touch
   in the letter. I have solved the bug.  Method:

           In the kupu\apache-lenya\lenya\content2edit.xsl, you must add the
three line with    the red font.

   <!-- this template converts the object tag to img (for compatiblity with
older browsers
    for more, see http://www.xml.com/pub/a/2003/07/02/dive.html -->
   <xsl:template name="object2img">
      <img border="0">
        <xsl:attribute name="src">
          <xsl:choose>
*            <xsl:when test="starts-with(@data, 'http://')">
              <xsl:value-of select="@data"/>
            </xsl:when>*
            <xsl:when test="not(starts-with(@data, '/'))">
              <xsl:value-of select="$nodeid"/>/<xsl:value-of
select="@data"/>
            </xsl:when>
            <xsl:otherwise>
              <xsl:value-of select="@data"/>
            </xsl:otherwise>
          </xsl:choose>

Good luck,

Cheng

2009/4/9 Vik Tara <vik@propco.co.uk>

> Hi,
>
> Do you see any errors in the firefox error console?
>
> Regards
>
> Vik
>
> Michael Keller wrote:
> > Hello,
> >
> > I'm new to lenya and I'm facing some problems with the insertion of
> > images into my website.
> >
> > What happened for now:
> >
> > - Downloaded and build lenya 2.0 from the lenya.apache.org site on my
> > Windows XP Machine.
> >
> > - Editited the page2xhtml.xsl of the default site to suite my needs
> >
> > - started to create xhtml pages in the site using Firefox 3.0.8
> >
> > - Uploaded an Image Asset to one of the created pages
> >
> > Now the problem: Either with Kupu or BXE I can't insert the uploaded
> > image into my page.
> >
> > In Kupu I can open the insert image window, which is showing me the
> > choice of "page library" and "pub library", but clicking on one of them
> > brings up the error message "Error loading
> >
> /default/authoring/Sportstunden/fraenkische?lenya.module=kupu&lenya.step=page_image_library:500"
> >
> >
> > In BXE I can also click the insert image button and in the windows which
> > is showing up I can see the uploaded image and select the image using
> > the radiobutton at the beginning od the line. After clicking "Insert
> > Image" the dialog disappears and nothing else happens. Even the selected
> > image is not inserted into the document.
> >
> > What can I do to fix that?
> >
> >
> > Thanks in advance
> >
> >
> > Michael
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
> > For additional commands, e-mail: user-help@lenya.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
> For additional commands, e-mail: user-help@lenya.apache.org
>
>

Mime
View raw message