lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vik Tara <...@propco.co.uk>
Subject Re: Lenya 2.0 with Eclipse
Date Sun, 17 Aug 2008 08:51:56 GMT
>
> I just gave it a quick try. You need to add all libs to the external
> configuration (ant build) to the classpath, but there are still some
> problems afterward.
Thanks for the pointer, I'll see if I can solve the other issues.


> I have not used this way of deployment since quite
> some time
I'd be really interested to know method's being implemented by others -
I am trying to find a way to do everything in a single ide.

Thanks

Vik

Thorsten Scherler wrote:
> On Tue, 2008-08-05 at 13:15 +0100, Vik Tara wrote:
>   
>> Sorry Thorsten - perhaps I wasn't clear in my original description of
>> the problem.
>>
>> I am able to build the targets on my box using ./build.sh without any
>> problem.
>>
>> What I am trying to do is execute the build targets in eclipse - after I
>>  have imported the eclipse project files.
>>
>> In my case I am trying to build the war (by importing build.xml into the
>> eclipse ant view and running the war target)
>>
>> This approach worked for me previously with Lenya 1.2.5
>>     
>
> I just gave it a quick try. You need to add all libs to the external
> configuration (ant build) to the classpath, but there are still some
> problems afterward. I have not used this way of deployment since quite
> some time, but maybe some other have and know how to quickly fix it.
>
> salu2
>
>   
>> Or am I looking at it the wrong way?
>>
>> Thanks
>>
>>
>> Vik
>>
>>
>>
>> Thorsten Scherler wrote:
>>     
>>> On Tue, 2008-08-05 at 12:42 +0100, Vik Tara wrote:
>>>       
>>>> Thorsten Scherler wrote:
>>>>         
>>>>> On Tue, 2008-08-05 at 12:00 +0100, Vik Tara wrote:
>>>>>           
>>>>>> Thanks Bhavya - i'll try that now.
>>>>>>
>>>>>> Does anyone know if there is an issue with the build targets in the
>>>>>> release version? It would be good to be able to work with the downloads
>>>>>> as well as getting it from svn.
>>>>>>             
>>>>> Hmm, it looks really wried, can you try the following and if it is
>>>>> working I will fix it for the next release that is coming very soon:
>>>>>
>>>>> in  src/targets/properties-build.xml
>>>>> look for <taskdef name="jing"
>>>>> classname="com.thaiopensource.relaxng.util.JingTask"/>
>>>>>
>>>>> and change it to:
>>>>>
>>>>> <taskdef name="jing" classpathref="classpath"
>>>>> classname="com.thaiopensource.relaxng.util.JingTask"/>
>>>>>
>>>>> salu2
>>>>>
>>>>>           
>>>> OK - tried that. Now the build fails with:
>>>>
>>>> apache-lenya-2.0/src/targets/properties-build.xml:169:
>>>> apache-lenya-2.0/build/lenya/lib not found.
>>>>         
>>>
>>> Hmm, I just tried in my local box (linux) without changing above file
>>> (please revert the changes before you try the following).
>>>
>>> I did after downloading and and extracting:
>>> cd apache-lenya-2.0
>>> ./build.sh
>>> cd externals/cocoon_2_1_x/
>>> ./build.sh eclipse-project
>>> cd ../../
>>> ./build.sh eclipse-project
>>>
>>> and do not get any errors.
>>>
>>> Are you on windows? If so the only thing that you need to change
>>> is ./build.sh to build.bat.
>>>
>>> salu2
>>>
>>>
>>>       
>>>> What could I try next?
>>>>
>>>>
>>>>         
>>>>>> Bhavya Sharma wrote:
>>>>>>             
>>>>>>> sorry no idea about downloaded lenya  however if you try
>>>>>>> to check it out from svn and then build it , it will work fine
and even you
>>>>>>> don,t need to
>>>>>>> explicitly download the cocoon as it has its own cocoon.
>>>>>>> so u can directly build it.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Tue, Aug 5, 2008 at 1:12 PM, Vik Tara <vik@propco.co.uk>
wrote:
>>>>>>>
>>>>>>>               
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> I'm trying to get Lenya 2.0 to build inside eclipse following
the
>>>>>>>> instructions here:
>>>>>>>> http://lenya.apache.org/docu20/tutorials/setupide.html
>>>>>>>>
>>>>>>>> I have downloaded Lenya 2.0 and Cocoon 2.1.11 rather than
checking out
>>>>>>>> from SVN.
>>>>>>>>
>>>>>>>> However when I try to build using any of the ant targets
I get:
>>>>>>>>
>>>>>>>> apache-lenya-2.0/src/targets/properties-build.xml:167: taskdef
class
>>>>>>>> com.thaiopensource.relaxng.util.JingTask cannot be found
>>>>>>>>
>>>>>>>> Maybe I have made a mistake somewhere - has anyone else faced
this issue?
>>>>>>>>
>>>>>>>> Regards
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Vik
>>>>>>>>
>>>>>>>>
>>>>>>>> ---------------------------------------------------------------------
>>>>>>>> To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
>>>>>>>> For additional commands, e-mail: user-help@lenya.apache.org
>>>>>>>>
>>>>>>>>
>>>>>>>>                 
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
>>>>>> For additional commands, e-mail: user-help@lenya.apache.org
>>>>>>
>>>>>>             
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
>>>> For additional commands, e-mail: user-help@lenya.apache.org
>>>>
>>>>         
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
>> For additional commands, e-mail: user-help@lenya.apache.org
>>
>>     


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
For additional commands, e-mail: user-help@lenya.apache.org


Mime
View raw message