lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From solprovi...@apache.org
Subject Re: Startup Script for Lenya
Date Fri, 04 Jul 2008 05:27:34 GMT
Hi Brian,

The error message comes from a check in lenya.sh that JAVA_HOME is not
the empty string.  From your information, that message should not
appear.  You could add your echo test to lenya.sh.

Lenya-1.2.5 was released on 2007-02-28 before my changes to lenya.sh
were committed.

lenya.sh running on my production RedHat server is attached.  The
changes allow running multiple copies of Lenya from different
directories.
- Lenya loads from the current directory rather than the global
LENYA_HOME (otherwise Lenya loaded from the LENYA_HOME directory
regardless of which lenya.sh was called.)
- JETTY_PORT is specified in lenya.sh (so different copies can be run
simultaneously without port conflicts.)
- Added the "stop" command.
- If Lenya is already running from this directory, this instance of
Lenya will stop before starting again.

A slightly modified version was committed on 2007-12-07:
   http://svn.apache.org/viewvc/lenya/branches/BRANCH_1_2_X/lenya.sh?view=markup
The only difference between my production version and the 1.2.X branch
is we changed the directory resolution to use "dirname" because the
1978 version of sh could not handle parsing with "expr".  The
committed code is better -- more concise and works on every flavor of
*nix.  (I did not "fix" my working production server with this
change.)

These changes have not been ported to trunk (Lenya-2.X) yet.

None of this affects JAVA_HOME -- the test is the same in 1.2.5,
1.2.X, and trunk.

Summarizing your problem:
- JAVA_HOME is set correctly in the init script. This should be a global change.
- JAVA_HOME is set correctly when running lenya.sh as the lenya user
after all init processes complete.
- JAVA_HOME is not set correctly when using sudo to run Lenya from the
init script.
- The only difference is the released version of lenya.sh would run
Lenya from the LENYA_HOME directory rather than the current directory.
 This only matters if LENYA_HOME is not set to the current Lenya
directory and should not matter as the JAVA_HOME test precedes any use
of LENYA_HOME.

Next Steps:
- Upgrade lenya.sh.  The committed version is best.  (Or just checkout 1.2.X.)
- Check if anything else is setting JAVA_HOME.  (This does not make
sense.  Even if you export JAVA_HOME somewhere else, you are unlikely
to set it to the empty string.)

Wishing for a better answer,
solprovider


On 6/30/08, Kimsey-Hickman, Brian <Brian.Kimsey-Hickman@occompt.com> wrote:
> Solprovider, thanks for the help.
>  I checked for that line in the export list and I do have a line:
>  Declare -x JAVA_HOME="/usr/local/src/j2sdk1.4.2._17"
>
>  When I su to user lenya (the username I am running in lenya125).
>  However. I am still getting that JAVA_HOME error when I run the lenya125
>  script.
>  I do have the sdk version of JAVA installed (j2sdk1.4.2_17) and lenya
>  works when I run ./lenya.sh from the command line as user lenya.
>
>  I must be overlooking something but I can't figure out what.
>  Brian

Mime
View raw message