lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Hartmann <andr...@apache.org>
Subject Re: Tomcat library problem [was: TinyMCE problems]
Date Fri, 11 Apr 2008 16:59:34 GMT
Andreas Hartmann schrieb:
> Hi Rainer,
> 
> Rainer Schöpf schrieb:
>> Hello,
>>
>> followup to the second problem I reported yesterday. This took some 
>> time to unravel, so I thought I should share my findings.
> 
> thanks a lot for digging into this and sharing the results!
> We'll add this to the FAQ.

Done (in the new documentation, not published yet).
Thanks again!

-- Andreas

> 
> -- Andreas
> 
>>
>> It turned out that at some point the standard Java libawt.so is used, 
>> which in turn tries to load libmlib_image.so (located in the same 
>> directory). However, the directory in question is not in the standard 
>> library load path and loading fails. After setting the LD_LIBRARY_PATH 
>> environment variable for the tomcat process, the problem went away.
>>
>> Determining the cause of the problem was not easy.
>>
>> The first time the error appears after tomcat is started, there is one 
>> error message of type java.lang.UnsatisfiedLinkError, mentioning 
>> libawt.so. Afterwards one sees this:
>>
>>  > http-8280-Processor25 INFO  sitemap - Redirecting to 
>> 'cocoon:/view/tab'
>>  > http-8280-Processor25 ERROR [/lenya].[Cocoon] - Servlet.service() 
>> for servlet
>>  > Cocoon threw exception
>>  > java.lang.NoClassDefFoundError
>>  >     at org.apache.batik.bridge.BridgeContext.<init>(Unknown Source)
>>  >     at org.apache.batik.bridge.BridgeContext.<init>(Unknown Source)
>>  >     at 
>> org.apache.batik.transcoder.SVGAbstractTranscoder.createBridgeContext(Unknown 
>> > Source)
>>
>> Unfortunately, versions of Java 1.5.x before 1.5.0_14 (and after 
>> 1.5.0_10) do not display a sensible error message together with the 
>> unsatified link error:
>>
>> java.lang.UnsatisfiedLinkError: 
>> /usr/lib/j2sdk1.5-sun/jre/lib/i386/libawt.so: Can't load IA 32-bit .so 
>> on a IA 32-bit platform
>>
>> Upgrading to 1.5.0_14 resulted in a sensible error message about 
>> libmlib_image.so not being found.
>>
>>    Rainer Schöpf
> 
> 


-- 
Andreas Hartmann, CTO
BeCompany GmbH
http://www.becompany.ch
Tel.: +41 (0) 43 818 57 01


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
For additional commands, e-mail: user-help@lenya.apache.org


Mime
View raw message