lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jann Forrer <jann.for...@id.unizh.ch>
Subject Re: is anyone running 1.4-trunk on tomcat successfully?
Date Tue, 10 Oct 2006 20:05:41 GMT
On Tue, 10 Oct 2006, Jörn Nettingsmeier wrote:

Hi Jörn

> hi jan!
>
> Jann Forrer wrote:
>> Jörn Nettingsmeier wrote:
>>> hi everyone!
>>> 
>>> 
>>> i'm having weird library issues (or so i think) while running
>>> lenya-trunk in tomcat. xalan seems unable to map namespaces to prefixes,
>>> and this has been reported as a jar incompatibility issue before
>>> is anyone currently using this setup successfully?
>>> 
>> 
>> I am rununing 1.4( svn Revision: 450435) on tomcat.
>> 
>
> i have 453639.
>
> tried rolling back to your revision, re-deployed, deleted tomcat work dir, 
> restarted, same problem.
>
>>> if so, would you mind sharing
>>> a) your tomcat and java version
>> 
>> java version "1.4.2_06
>> Apache Tomcat/5.0.30
>
> same here..
>
>>> b) your architecture and os
>> Linux  2.6.13-15.11-smp
>> SUSE LINUX 10.0 (X86-64)
>
> same here, except i'm on a 32bit machine.
>
>>> c) a listing of your tomcat endorsed lib directory and the
>>> lenya/WEB-INF/lib directory
>>> 
>> 
>> common endorsed:
>> jakarta-bcel-20040329.jar  jakarta-regexp-1.4.jar  xalan-2.7.0.jar
>> xercesImpl-2.8.1.jar  xml-apis-1.3.03.jar
>
> same here. i had to delete two symlinks for xml-apis and xerces that
> pointed into the java sdk.
>
>> You could also test whether you hava a $JAVA_HOME/jre/endorsed (and some
>> xml libraries within this dir. They might conflict with the libraries
>> located in tomcat's common endorsed ....).
>
> it's empty.
>
>
>
> this one is tricky...
>
>

Indeed :-( Did you try to make a ./build.sh clean before redeploying?
But most likely you already tried it .... but this is the only 
suggestion which crosses my mind (at the moment).

Jann


Mime
View raw message