lenya-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörn Nettingsmeier <netti...@apache.org>
Subject Re: is anyone running 1.4-trunk on tomcat successfully?
Date Tue, 10 Oct 2006 21:05:33 GMT
hi simon!

simon litwan wrote:
> Jörn Nettingsmeier schrieb:
>> hi everyone!
>>
>>
>> i'm having weird library issues (or so i think) while running
>> lenya-trunk in tomcat. xalan seems unable to map namespaces to prefixes,
>> and this has been reported as a jar incompatibility issue before
>> is anyone currently using this setup successfully?
>>
>> if so, would you mind sharing
>> a) your tomcat and java version
> jakarta-tomcat-5.0.28
> j2sdk1.4.2_10
> 
>> b) your architecture and os
> x86, ubunut 6.06
>> c) a listing of your tomcat endorsed lib directory and the
>> lenya/WEB-INF/lib directory
> ls common/endorsed/
> jakarta-bcel-20040329.jar  xalan-2.6.1-dev-20041008T0304.jar  
> xercesImpl-2.8.0.jar  xml-apis.jar
> jakarta-regexp-1.3.jar     xalan-2.7.0.jar                    
> xercesImpl-2.8.1.jar
> jakarta-regexp-1.4.jar     xercesImpl-2.6.2.jar               
> xml-apis-1.3.02.jar
> old                        xercesImpl-2.7.1.jar               
> xml-apis-1.3.03.jar

funny. after re-reading the tomcat/lenya install instructions, i'm sorry
to say that your setup does not work :)
that's a whole zoo of xerces versions you have in there... according to
the docs, this should lead to problems. weird.

did you do any cleanup after deploying? how exactly did you deploy to
tomcat? with ./build.sh and the appropriate settings in
local.build.properties, or via a war file?

maybe i've cleaned up too much?


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@lenya.apache.org
For additional commands, e-mail: user-help@lenya.apache.org


Mime
View raw message