lenya-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Frovarp <Richard.Frov...@ndsu.edu>
Subject Re: xmldiff module
Date Mon, 15 Jun 2009 20:31:34 GMT
Alexander S. Sizemin wrote:
> Hi devs,
> I'm not much experienced in the field of licencing,
> so I have a question regarding a third-party code usage.
>
> What I want to figure out is if there any way to use opensource 
> non-ASF code witin the Lenya module devlopment?
> Particularly, one of such non-ASF licences is QPL v1.0 
> (http://en.wikipedia.org/wiki/QPL).
> I can't say there is a great need of using the particular solution, 
> which is under QPL,
> but it's usage will give a much better outcome and will help to solve 
> problems more effectively,
> that's why it is so desirable for me.

According to the Legal Affairs website, QPL is not compatible with the 
Apache License. You can use non-ASF licenses if it compatible. Here is a 
list that you can reference.

http://apache.org/legal/resolved.html

So it would be preferable to avoid those that can't be used. Some of the 
editors use incompatible licenses, and thus requires the user to 
separately download and go through some extra steps. I would greatly 
like to avoid this issue for this project.

Richard

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lenya.apache.org
For additional commands, e-mail: dev-help@lenya.apache.org


Mime
View raw message