lenya-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Hartmann <andr...@apache.org>
Subject Re: ANTLR and Java 1.4
Date Tue, 13 May 2008 13:18:29 GMT
Jann Forrer schrieb:

[...]

>> If requiring Java 5 is not an option, we have to include the
>> pre-generated lexer and parser Java files. The absolute paths you
>> mentioned shouldn't do any harm, since they only occur in comments and
>> in a method that is never called. Of course it would nevertheless be
>> nice to get rid of them.
>>
> Java 1.5 is ok for me. However on one of our server we still use 1.4.2.
> Could we simply copy the compiled lexer and parser classes to this server?

That wouldn't work (you would also get the 
UnsupportedClassVersionError), but you could try to copy the generated 
lexer and parser Java files in 
build/lenya/src/org/apache/lenya/ac/impl/antlr to the server and let the 
build process compile them.

-- Andreas


-- 
Andreas Hartmann, CTO
BeCompany GmbH
http://www.becompany.ch
Tel.: +41 (0) 43 818 57 01


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lenya.apache.org
For additional commands, e-mail: dev-help@lenya.apache.org


Mime
View raw message