lenya-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Wechner <michael.wech...@wyona.com>
Subject Re: Image upload with Bitflux in 1.2.5-dev of 01.03.2006
Date Tue, 04 Apr 2006 09:20:52 GMT
Markus Angst wrote:

> Michael Wechner wrote:
>
>> Markus Angst wrote:
>>
>>> Hello,
>>>
>>> I have Lenya 1.2.5-dev from SVN of 01.03.2006.
>>>
>>> There is a problem with the image upload in the Bitflux editor. When I
>>> click on the image icon, the "Insert Image" popup opens as expected, 
>>> but
>>> this action generates a log entry:
>>
>>
>> have you enabled the upload functionality within 
>> (local.)build.properties?
>>
>> enable.uploads=true (it's disabled by default for security reasons)
>
>
> Yes, I know; I have enabled it. Sorry for not having mentioned it before.
>
> While we are at this subject: Setting enable.uploads in l.b.p and 
> running a build has no effect. I have to change the parameter 
> enable-uploads in build/lenya/webapp/WEB-INF/web.xml to get a result.


what Cocoon version are you using? There was a bug within which I have 
recently fixed, but that was for Lenya 1.4-dev
and Cocoon-2.1.9-dev

>
>
> I found out, that the log message I mentioned has nothing to do with 
> the upload problem. The same message is also logged when I 
> successfully upload a file via Site/Assets.
>
> The image upload problem still exists. You can reproduce it at 
> http://lenya.zones.apache.org:8888. Being able to upload an image 
> under Site/Assets proves that enable-uploads is set to true. Still you 
> can't upload an image in Bitflux.
>
> I would appreciate it very much if somebody could have a look at this.


please add an entry to Bugzilla.

Thanks

Michi

>
> Thanks!
> Markus
>
>
>> HTH
>>
>> Michi
>>
>>> ------------------------
>>> 671047 2006-02-14 22:05:49,000 [PoolThread-4] ERROR
>>> core.i18n.reload():324  - Bundle <cocoon://i18n-catalogue/cmsui.xml> 
>>> not
>>> loaded: Exception
>>> org.apache.cocoon.ProcessingException: Sitemap: error when calling
>>> sub-sitemap
>>>     at <map:mount> -
>>> file:/C:/lenya/lenya-1.2.5-dev/build/lenya/webapp/sitemap.xmap:461:102
>>>     at
>>> org.apache.cocoon.ProcessingException.throwLocated(ProcessingException.java:112)

>>>
>>>     at
>>> org.apache.cocoon.components.treeprocessor.sitemap.MountNode.invoke(MountNode.java:121)

>>>
>>>     at
>>> org.apache.cocoon.components.treeprocessor.AbstractParentProcessingNode.invokeNodes(AbstractParentProcessingNode.java:46)

>>>
>>>
>>> ... about 120 more lines ...
>>> ------------------------
>>>
>>> When I choose a file and click "Add", the form gets cleared and when I
>>> close the form no image appears in the editing area.
>>> Whe I upload a image via Site / Assets and select this file on the
>>> "Insert Image" popup all works as expected.
>>>
>>> Thanks!
>>>
>>> Markus Angst, Inventec Informatik AG, Zurich, Switzerland
>>>
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@lenya.apache.org
>>> For additional commands, e-mail: dev-help@lenya.apache.org
>>>
>>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lenya.apache.org
> For additional commands, e-mail: dev-help@lenya.apache.org
>
>


-- 
Michael Wechner
Wyona      -   Open Source Content Management   -    Apache Lenya
http://www.wyona.com                      http://lenya.apache.org
michael.wechner@wyona.com                        michi@apache.org
+41 44 272 91 61


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lenya.apache.org
For additional commands, e-mail: dev-help@lenya.apache.org


Mime
View raw message