lenya-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug Chestnut <dh...@virginia.edu>
Subject Re: error when trying to edit a document
Date Tue, 07 Dec 2004 14:28:28 GMT
Ok, I must have been up too late last night.
This must just be svn user error on my part.
I did a svn co http://svn.apache.org/repos/asf/lenya/trunk lenya-1.4 
yesterday afternoon, built lenya, restarted tomcat, and got an error 
about invalid characters. My edit-document.js file appeared to be 
corrupt with >>>>>>> characters inbetween the lines that had changed

(showing the last two changes from antonio and gregor).  I removed the 
offending lines (lines before changes had been made) and rebuilt, all 
was well again in my world.  I assumed that the corrupt file that I had 
was from the trunk, and not from my lack of experience with svn.  Sorry, 
I will be sure to double check the web interface to cvs next time.

Should I go ahead and close the bugzilla entry? use INVALID? (dumb XXXX 
isn't listed in the resolution types).


Rolf Kulemann wrote:
> Hi Doug, it seeems you have only added some empty lines?
> 
> Doug Chestnut wrote:
> 
>> Opps, Sorry forgot to mention, this is for 1.4
>> Here is the Bugzilla link:
>> http://issues.apache.org/bugzilla/show_bug.cgi?id=32555
>>
>> Doug Chestnut wrote:
>>
>>> Hi Gregor,
>>> Still seems to be a problem with
>>> /src/webapp/lenya/usecases/edit-document.js
>>> Here is the patch:
>>>
>>> Index: edit-document.js
>>> ===================================================================
>>> --- edit-document.js    (revision 109934)
>>> +++ edit-document.js    (working copy)
>>> @@ -40,6 +40,7 @@
>>>      try {
>>>          var flowHelper = new FlowHelper();
>>>          var resolver = cocoon.getComponent(SourceResolver.ROLE);
>>> +
>>>          var dstUri = 
>>> flowHelper.getPageEnvelope(cocoon).getDocument().getSourceURI();
>>>
>>>          SourceUtil.copy(resolver, cocoon.parameters["sourceUri"], 
>>> dstUri, _getParameter("useBuffer", "false") == "true");
>>> @@ -56,7 +57,9 @@
>>>              cocoon.redirectTo(_getParameter("redirectUrl", "FIXME"));
>>>
>>>      } catch (exception) {
>>> +
>>>          cocoon.log.error("Can not edit document.", 
>>> exception.toString());
>>> +
>>>      } finally {
>>>          if(resolver != null)
>>>              cocoon.releaseComponent(resolver);
>>>
>>> Gregor J. Rothfuss wrote:
>>>
>>>> Doug Chestnut wrote:
>>>>
>>>>> Hi Developers,
>>>>> I have installed lenya from the trunk (I guess that this is 1.4) 
>>>>> and have noticed some errors with the default pub.
>>>>> I think that I have taken care of my biggest problem.  I couldn't 
>>>>> edit a doc, with any of the editors (well actually I only tried 
>>>>> "one form" and bitflux).  Bitflux gave an error when I tried to 
>>>>> save, and "one form" would just give me a blank page and a log 
>>>>> entry in the error log:
>>>>>
>>>>
>>>> thanks, applied
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail:              dev-unsubscribe@lenya.apache.org
>>> For additional commands, e-mail:            dev-help@lenya.apache.org
>>> Apache Lenya Project                          http://lenya.apache.org
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail:              dev-unsubscribe@lenya.apache.org
>> For additional commands, e-mail:            dev-help@lenya.apache.org
>> Apache Lenya Project                          http://lenya.apache.org
>>
>>
> 

---------------------------------------------------------------------
To unsubscribe, e-mail:              dev-unsubscribe@lenya.apache.org
For additional commands, e-mail:            dev-help@lenya.apache.org
Apache Lenya Project                          http://lenya.apache.org


Mime
View raw message