lens-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From amareshw...@apache.org
Subject [2/2] incubator-lens git commit: LENS-553 : Move Lens compile version to Java 7 (Arshad Matin via amareshwari)
Date Fri, 15 May 2015 03:51:46 GMT
LENS-553 : Move Lens compile version to Java 7 (Arshad Matin via amareshwari)


Project: http://git-wip-us.apache.org/repos/asf/incubator-lens/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-lens/commit/a6c40f4d
Tree: http://git-wip-us.apache.org/repos/asf/incubator-lens/tree/a6c40f4d
Diff: http://git-wip-us.apache.org/repos/asf/incubator-lens/diff/a6c40f4d

Branch: refs/heads/master
Commit: a6c40f4d20e883f6ca1c7f4e2c203248ff1f832c
Parents: 359bb68
Author: Arshad Matin <arshadmatin20@gmail.com>
Authored: Fri May 15 09:21:32 2015 +0530
Committer: Amareshwari Sriramadasu <amareshwari@apache.org>
Committed: Fri May 15 09:21:32 2015 +0530

----------------------------------------------------------------------
 README.md                                        | 2 +-
 lens-dist/src/deb/control/client-control/control | 2 +-
 lens-dist/src/deb/control/server-control/control | 2 +-
 lens-server/pom.xml                              | 2 +-
 pom.xml                                          | 6 +++---
 src/site/apt/admin/deployment.apt                | 2 +-
 src/site/apt/developer/contribute.apt            | 2 +-
 7 files changed, 9 insertions(+), 9 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-lens/blob/a6c40f4d/README.md
----------------------------------------------------------------------
diff --git a/README.md b/README.md
index c9163ee..4cd8e79 100644
--- a/README.md
+++ b/README.md
@@ -5,7 +5,7 @@ Apache Lens is a unified Analytics Platform. Lens aims to cut the Data Analytics
 across multiple tiered data stores and optimal execution environment for the analytical query.
 
 Building source :
-Requires JDK(1.6, 1.7) and Apache Maven(3.x) to be installed for the build. Build does not
pass with JDK(1.8) yet.
+Requires JDK(1.7) and Apache Maven(3.x) to be installed for the build. Build does not pass
with JDK(1.8) yet.
 Please run <mvn clean package> to build the project.
 
 See [Development Environment Setup] (http://lens.incubator.apache.org/developer/contribute.html#Development_Environment_Setup)

http://git-wip-us.apache.org/repos/asf/incubator-lens/blob/a6c40f4d/lens-dist/src/deb/control/client-control/control
----------------------------------------------------------------------
diff --git a/lens-dist/src/deb/control/client-control/control b/lens-dist/src/deb/control/client-control/control
index 51d3c9f..5c8fb38 100644
--- a/lens-dist/src/deb/control/client-control/control
+++ b/lens-dist/src/deb/control/client-control/control
@@ -21,7 +21,7 @@ Version: [[project.version]]
 Section:  misc
 Priority: high
 Architecture: all 
-Depends: sun-java6-jre | java2-runtime
+Depends: sun-java7-jre | java2-runtime
 Maintainer: dev@lens.incubator.apache.org
 Description: Apache Lens Client Distribution
 Distribution: alpha

http://git-wip-us.apache.org/repos/asf/incubator-lens/blob/a6c40f4d/lens-dist/src/deb/control/server-control/control
----------------------------------------------------------------------
diff --git a/lens-dist/src/deb/control/server-control/control b/lens-dist/src/deb/control/server-control/control
index b8f7333..de8771c 100644
--- a/lens-dist/src/deb/control/server-control/control
+++ b/lens-dist/src/deb/control/server-control/control
@@ -21,7 +21,7 @@ Version: [[project.version]]
 Section:  misc
 Priority: high
 Architecture: all 
-Depends: sun-java6-jre | java2-runtime
+Depends: sun-java7-jre | java2-runtime
 Maintainer: dev@lens.incubator.apache.org
 Description: Apache Lens Server Distribution
 Distribution: alpha

http://git-wip-us.apache.org/repos/asf/incubator-lens/blob/a6c40f4d/lens-server/pom.xml
----------------------------------------------------------------------
diff --git a/lens-server/pom.xml b/lens-server/pom.xml
index 75d1618..bb12e00 100644
--- a/lens-server/pom.xml
+++ b/lens-server/pom.xml
@@ -341,7 +341,7 @@
     <profile>
       <id>enunciate</id>
       <activation>
-        <jdk>[1.6,1.7,1.8)</jdk>
+        <jdk>[1.7,1.8)</jdk>
       </activation>
       <build>
         <plugins>

http://git-wip-us.apache.org/repos/asf/incubator-lens/blob/a6c40f4d/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index 6a62aff..a9a3969 100644
--- a/pom.xml
+++ b/pom.xml
@@ -34,8 +34,8 @@
     <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
 
     <!-- java and javax -->
-    <java.source.version>1.6</java.source.version>
-    <java.target.version>1.6</java.target.version>
+    <java.source.version>1.7</java.source.version>
+    <java.target.version>1.7</java.target.version>
     <servlet3.version>3.0.1</servlet3.version>
     <servlet.api.version>2.5</servlet.api.version>
     <jsp.api.version>2.0</jsp.api.version>
@@ -1291,7 +1291,7 @@
     <profile>
       <id>enunciate</id>
       <activation>
-        <jdk>[1.6,1.7,1.8)</jdk>
+        <jdk>[1.7,1.8)</jdk>
       </activation>
       <build>
         <plugins>

http://git-wip-us.apache.org/repos/asf/incubator-lens/blob/a6c40f4d/src/site/apt/admin/deployment.apt
----------------------------------------------------------------------
diff --git a/src/site/apt/admin/deployment.apt b/src/site/apt/admin/deployment.apt
index 7fbeb56..088a695 100644
--- a/src/site/apt/admin/deployment.apt
+++ b/src/site/apt/admin/deployment.apt
@@ -36,7 +36,7 @@ Lens server deployment
 
 * Dependencies and their versions
 
-   * Requires java 1.6+, Does not work with java 1.8 yet.
+   * Requires java 1.7+.
 
    * Requires Hadoop 2.x+. Tested upto hadoop 2.4.
 

http://git-wip-us.apache.org/repos/asf/incubator-lens/blob/a6c40f4d/src/site/apt/developer/contribute.apt
----------------------------------------------------------------------
diff --git a/src/site/apt/developer/contribute.apt b/src/site/apt/developer/contribute.apt
index 77bdc2b..73206a8 100644
--- a/src/site/apt/developer/contribute.apt
+++ b/src/site/apt/developer/contribute.apt
@@ -67,7 +67,7 @@ Developer Documentation : How to contribute to Apache Lens?
 
 ** Build tools
 
-  * A Java Development Kit. You can use java6 or java7. Build does not pass with java8 yet.
+  * A Java Development Kit. You can use java7. Build does not pass with JDK(1.8) yet.
 
   * Apache maven (3.x+)
 


Mime
View raw message