kylin-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ShaoFeng Shi <shaofeng...@apache.org>
Subject Kylin Branches for Hadoop 3.1/HBase 2.0
Date Tue, 11 Sep 2018 01:33:08 GMT
Hello Kylin users,

As some users start to move to Hadoop 3.0 and HBase 2.0. We cut off two
branches for the new version:


   - master-hadoop3.1: Kylin master code base with Hadoop 3.1 and HBase 2.0
   API
   - 2.5.x-hadoop3.1: Kylin 2.5.x code base with Hadoop 3.1 and HBase 2.0
   API

The compilation and "mvn test" are good. And we manually tested
"2.5.x-hadoop3.1" branch on a Hortonworks HDP 3.0 cluster, the major
functions are okay except the Spark cube engine. Please use MR engine.

We will periodically rebase them against the master/2.5.x branches. You can
build a binary package with "build/scripts/package.sh", but the "cdh57"
profile won't work I think. We will investigate Cloudera CDH 6.0 later to
see whether its API is compatible.
-- 
Best regards,

Shaofeng Shi 史少锋

Mime
View raw message