kylin-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Hu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KYLIN-3481) Kylin Jdbc: Shaded dependencies should not be transitive
Date Fri, 03 Aug 2018 04:19:00 GMT

     [ https://issues.apache.org/jira/browse/KYLIN-3481?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ian Hu updated KYLIN-3481:
--------------------------
    Description: 
kylin-jdbc use dependencies as shaded, so they should not be transitive.

As far as I known, SHADE a dependency to avoid dependency conflict, but at v2.4.0, the dependencies
in kylin-jdbc are default compile scope and are transitive resolved, that may cause some dependency
conflicts.

We should mark shaded dependencies as optional

  was:
kylin-jdbc use dependencies as shaded, so they should not be transitive.

As far as I known, SHADE a dependency to avoid dependency conflict, but at v2.4.0, the dependencies
in kylin-jdbc are default compile scope and are transitive resolved, that may cause some dependency
conflicts.


> Kylin Jdbc: Shaded dependencies should not be transitive
> --------------------------------------------------------
>
>                 Key: KYLIN-3481
>                 URL: https://issues.apache.org/jira/browse/KYLIN-3481
>             Project: Kylin
>          Issue Type: Improvement
>          Components: Driver - JDBC
>    Affects Versions: v2.4.0
>            Reporter: Ian Hu
>            Assignee: Ian Hu
>            Priority: Major
>
> kylin-jdbc use dependencies as shaded, so they should not be transitive.
> As far as I known, SHADE a dependency to avoid dependency conflict, but at v2.4.0, the
dependencies in kylin-jdbc are default compile scope and are transitive resolved, that may
cause some dependency conflicts.
> We should mark shaded dependencies as optional



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message