kylin-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guangyao Li (JIRA)" <>
Subject [jira] [Commented] (KYLIN-3239) Refactor the ACL code about "checkPermission" and "hasPermission"
Date Tue, 06 Feb 2018 01:54:00 GMT


Guangyao Li commented on KYLIN-3239:

There are two permissions patterns "checkPermission" and "hasPermission" in the file "AclEvaluate.Java".

The "checkPermission" method should check the permission of the current user and doesn't
need to return a value. This is a void method.

The "hasPermission" method is a boolean method, and should return a value about "ture" or

The refactoring covers the root file "AclEvaluate.Java" and some else files using "checkPermission"
or "hasPermission" method.

Now, the files using "checkPermission" or "hasPermission" method have "ProjectController.Java,
CubeService.Java, ModelService.Java, ProjectService.Java".

> Refactor the ACL code about "checkPermission" and "hasPermission"
> -----------------------------------------------------------------
>                 Key: KYLIN-3239
>                 URL:
>             Project: Kylin
>          Issue Type: Improvement
>          Components: Security
>    Affects Versions: v2.2.0
>            Reporter: Guangyao Li
>            Priority: Minor
>             Fix For: v2.3.0
> According to the design of "checkPermission" and "HasPermission",
> Refactoring the ACL code

This message was sent by Atlassian JIRA

View raw message