kylin-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Billy Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KYLIN-2933) Fix compilation against the Kafka 1.0.0 release
Date Mon, 06 Nov 2017 14:39:01 GMT

    [ https://issues.apache.org/jira/browse/KYLIN-2933?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16240378#comment-16240378
] 

Billy Liu commented on KYLIN-2933:
----------------------------------

[~Shaofengshi], I think we could remove the getBrokers() in KafkaClusterConfig. Then no SecurityProtocol
dependency anymore. No need to upgrade the Kafka client library. 

> Fix compilation against the Kafka 1.0.0 release
> -----------------------------------------------
>
>                 Key: KYLIN-2933
>                 URL: https://issues.apache.org/jira/browse/KYLIN-2933
>             Project: Kylin
>          Issue Type: Bug
>            Reporter: Ted Yu
>            Assignee: Shaofeng SHI
>
> Due to change of class location of SecurityProtocol, KafkaClusterConfig.java needs to
be modified so that it compiles against the Kafka 1.0.0 release:
> {code}
> -import org.apache.kafka.common.protocol.SecurityProtocol;
> +import org.apache.kafka.common.security.auth.SecurityProtocol;
> {code}
> A compatibility layer may be needed if we support multiple Kafka releases simultaneously.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message