kylin-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shaofeng SHI (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (KYLIN-2188) Kylin does not compile with HBase 1.2
Date Wed, 29 Nov 2017 07:00:05 GMT

     [ https://issues.apache.org/jira/browse/KYLIN-2188?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Shaofeng SHI closed KYLIN-2188.
-------------------------------
    Resolution: Fixed

Please upgrade Kylin to a newer version like 2.1, which supports HBase 1.1+

> Kylin does not compile with HBase 1.2
> -------------------------------------
>
>                 Key: KYLIN-2188
>                 URL: https://issues.apache.org/jira/browse/KYLIN-2188
>             Project: Kylin
>          Issue Type: Bug
>          Components: Storage - HBase
>    Affects Versions: v1.5.3, v1.5.4, v1.5.4.1
>         Environment: CentOS Linux release 7.2.1511、maven 3.2.5、jdk1.7.0_80
>            Reporter: Qiang Zhang
>            Assignee: liyang
>              Labels: patch
>
> The RegionScanner and InternalScanner interface was different between hbase-server-1.2.x.jar
and hbase-server-0.9.8.jar. The AggregationRegionScanner class inherited the RegionScanner
interface. But it couldn't be compatible with hbase-server-1.2.x.jar and hbase-server-0.9.8.jar.
> The reappear steps is as following:
> 1. Get source code using git from git://git.apache.org/kylin.git;
> 2. Run the mvn command to compile the kylin project;
> 3. Compile successfully;
> 4. Modify the value of the <hbase-hadoop2.version> to 1.2.0 in the pom.xml of the
kylin project;
> 5. Run the mvn command to compile the kylin project;
> 3. Compile fail;



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message