kylin-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mvishnubhatta <mvishnubha...@argusinformation.com>
Subject Re: Kylin Start fails with NoClassDefFoundError on AWS EMR Edge Node
Date Thu, 09 Apr 2020 13:20:30 GMT
Thanks for the response. I tried /usr/lib/hive and it did not work. So I was
just trying out with /usr/lib/hive/lib. I checked again by changing it back
to /usr/lib/hive but it doesn't work.

I tried running a hive query and it does work (with /usr/lib/hive as
HVIE_HOME). Here is the test, for your information.

Logging initialized using configuration in
file:/etc/hive/conf.dist/hive-log4j2.properties Async: true
hive> INSERT INTO test_emr_from_airflow select '20200407','x','y',
CURRENT_TIMESTAMP;
Query ID = hadoop_20200409131925_720f87d1-067e-47be-80f6-5b7e296b0c79
Total jobs = 1
Launching Job 1 out of 1
Status: Running (Executing on YARN cluster with App id
application_1585860045700_0150)

----------------------------------------------------------------------------------------------
        VERTICES      MODE        STATUS  TOTAL  COMPLETED  RUNNING  PENDING 
FAILED  KILLED
----------------------------------------------------------------------------------------------
Map 1 .......... container     SUCCEEDED      1          1        0        0      
0       0
----------------------------------------------------------------------------------------------
VERTICES: 01/01  [==========================>>] 100%  ELAPSED TIME: 7.38 s
----------------------------------------------------------------------------------------------
Loading data to table default.test_emr_from_airflow
OK
Time taken: 20.152 seconds
hive>


--
Sent from: http://apache-kylin.74782.x6.nabble.com/

Mime
View raw message