kylin-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ShaoFeng Shi <shaofeng...@apache.org>
Subject [DISCUSS] Upgrade Kylin's dependency to Hadoop 3 / HBase 2
Date Wed, 26 Feb 2020 07:48:27 GMT
Hello, Kylin users and developers,

As we know Hadoop 3 and HBase 2 have released for some time. Kylin starts
to support Hadoop 3  since v2.5.0 in Sep 2018.  As the APIs of HBase 1 and
2 are incompatible, we need to keep different branches for them. And in
each release, we need to build separate packages and do a round of testing
for them separately. Furthermore, Cloudera's API difference with the Apache
release makes the situation worse; We need to build 4 binary packages for
reach release. That has spent much of our manual effort and computing
resources.

Today, Hadoop 3 + HBase 2 becomes enough mature and stable for production
use; And we see more and more users are starting to use the new versions.
We think it is time for Kylin to totally upgrade to the new version. So
that we can focus more on Kylin itself, instead of environments.

 Here is my proposal:
1) From Kylin 3.1,  Hadoop/HBase version upgrades to 3.1/2.1 (or a close
version);
2) Hadoop 2 and HBase 1 users can use Kylin 3.0 and previous releases;
3) We will re-evaluate the need for building binary packages for Cloudera
release. (we may raise another discuss)

Please let us know your comments. And please also understand with the
limited resource we couldn't support multiple Hadoop versions...

Thanks!

Best regards,

Shaofeng Shi 史少锋
Apache Kylin PMC
Email: shaofengshi@apache.org

Apache Kylin FAQ: https://kylin.apache.org/docs/gettingstarted/faq.html
Join Kylin user mail group: user-subscribe@kylin.apache.org
Join Kylin dev mail group: dev-subscribe@kylin.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message