kylin-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shaofeng SHI (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KYLIN-3517) Couldn't update coprocessor on HBase 2.0
Date Tue, 28 Aug 2018 00:32:00 GMT
Shaofeng SHI created KYLIN-3517:
-----------------------------------

             Summary: Couldn't update coprocessor on HBase 2.0
                 Key: KYLIN-3517
                 URL: https://issues.apache.org/jira/browse/KYLIN-3517
             Project: Kylin
          Issue Type: Bug
          Components: Storage - HBase
            Reporter: Shaofeng SHI


On HDP 3.0, run update coprocessor, got this error:

 
{code:java}
2018-08-28 00:24:26,683 ERROR [pool-7-thread-1] util.DeployCoprocessorCLI:383 : Error processing
KYLIN_O9JRT8XOQ9
java.lang.UnsupportedOperationException: HTableDescriptor is read-only
at org.apache.hadoop.hbase.client.ImmutableHTableDescriptor.getDelegateeForModification(ImmutableHTableDescriptor.java:59)
at org.apache.hadoop.hbase.HTableDescriptor.removeCoprocessor(HTableDescriptor.java:768)
at org.apache.kylin.storage.hbase.util.DeployCoprocessorCLI.resetCoprocessor(DeployCoprocessorCLI.java:300)
at org.apache.kylin.storage.hbase.util.DeployCoprocessorCLI$ResetCoprocessorWorker.run(DeployCoprocessorCLI.java:375)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
{code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message