kylin-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Li Yang <liy...@apache.org>
Subject Re: Build master-hadoop3.0 issue
Date Sat, 21 Oct 2017 00:47:01 GMT
Must be HBase API upgraded, the MockHTable impl needs to catch up.

On Mon, Oct 16, 2017 at 7:12 PM, Billy Liu <billyliu@apache.org> wrote:

> This is from HBase API. What's the HBase version you are building?
>
> 2017-10-16 10:57 GMT+08:00 Chen, Sammi <sammi.chen@intel.com>:
>
> >
> > Build master-hadoop3.0 with  Java 1.8.0_144 and Maven 3.5.0,    there is
> > one error.
> >
> > Failed to execute goal org.apache.maven.plugins:
> > maven-compiler-plugin:3.5.1:compile (default-compile) on project
> > kylin-server-base: Compilation failure
> > [ERROR] /Users/sammi/workspace/kylin/server-base/src/main/java/org/
> > apache/kylin/rest/security/MockHTable.java:[139,33] error: no suitable
> > constructor found for HTableDescriptor(String)
> > [ERROR]
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message