kudu-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Quanlong Huang" <huang_quanl...@126.com>
Subject How to install the latest kudu release and find the compatible Impala versions?
Date Mon, 21 May 2018 23:37:19 GMT
Hi friends,


We're trying to benchmark Impala+kudu to compare with other lambda architectures like Druid.
So we hope we can install the latest release version of Impala (2.12.0)  and kudu (1.7.0).
However, when following the installation guide in https://kudu.apache.org/docs/installation.html,
we can only install kudu-1.6.0-cdh5.14.2. Is it possible to install kudu-1.7 without manual
compilation?


Besides, I notice that Impala-2.5 is not compatible with kudu-1.6.0 since the CREATE TABLE
syntax for kudu is not recognized. Here's the error:
Query: create TABLE my_first_table
(
  id BIGINT,
  name STRING,
  PRIMARY KEY(id)
)
PARTITION BY HASH PARTITIONS 16
STORED AS KUDU
TBLPROPERTIES (
 'kudu.master_addresses' = 'lascorehadoop-15d26'
)
ERROR: AnalysisException: Syntax error in line 5:
  PRIMARY KEY(id)
          ^
Encountered: IDENTIFIER
Expected: ARRAY, BIGINT, BINARY, BOOLEAN, CHAR, DATE, DATETIME, DECIMAL, REAL, FLOAT, INTEGER,
MAP, SMALLINT, STRING, STRUCT, TIMESTAMP, TINYINT, VARCHAR

CAUSED BY: Exception: Syntax error


My further questions are
Is there a compatibility matrix for Impala and Kudu? 
Is Impala-2.12 compatible with Kudu-1.6.0 and Kudu-1.7.0?
Hopes to make this clear by your help.


Thanks,
Quanlong
Mime
View raw message