kudu-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jose antonio rodriguez diaz <josearodrigu...@gmail.com>
Subject How to access to apache kudu table created from impala using apache spark?
Date Sun, 28 May 2017 21:36:26 GMT
I downloaded the quickstart VM of apache kudu and I have followed the examples just like they
appears in this page https://kudu.apache.org/docs/quickstart.html <https://kudu.apache.org/docs/quickstart.html>,
in fact I created the table named "sfmta" but when I tried to to access to the kudu table
using spark-shell with the following sentence:

val df = spark.sqlContext.read.options(Map("kudu.master" -> "quickstart.cloudera:7051","kudu.table"
-> "sfmta")).kudu
I get this error

org.apache.kudu.client.NonRecoverableException: The table does not exist: table_name: "sfmta"
I have tried also specifying different tables names like "default:sfmta", "default::sfmta"
with the same result. Could you tell me why is this happening? why I can not access to kudu
table? is this for being created with impala?

Thanks in advance.
Mime
View raw message