kudu-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Bosshart <bossh...@gmail.com>
Subject Re: How to access to apache kudu table created from impala using apache spark?
Date Sun, 28 May 2017 22:39:24 GMT
Hi Jose -

You can verify the table names for the quickstart via the Kudu web UI at:

Can you try the table name "impala::default.sfmta"?

On Sun, May 28, 2017 at 4:36 PM, jose antonio rodriguez diaz <
josearodriguezd@gmail.com> wrote:

> I downloaded the quickstart VM of apache kudu and I have followed the
> examples just like they appears in this page https://kudu.apache.org/
> docs/quickstart.html, in fact I created the table named "sfmta" but when
> I tried to to access to the kudu table using spark-shell with the following
> sentence:
> val df = spark.sqlContext.read.options(Map("kudu.master" -> "quickstart.cloudera:7051","kudu.table"
-> "sfmta")).kudu
> I get this error
> org.apache.kudu.client.NonRecoverableException: The table does not exist: table_name:
> I have tried also specifying different tables names like "default:sfmta",
> "default::sfmta" with the same result. Could you tell me why is this
> happening? why I can not access to kudu table? is this for being created
> with impala?
> Thanks in advance.

Ryan Bosshart
612 730 4167

View raw message