Hi Alexey, 

The output of 'xcode-select -p' is: /Library/Developer/CommandLineTools

Hi Dan,

Yes, after run 'brew tap homebrew/dupes', krb5 can be installed successfully. But what do mean about 'CLT is not sufficient'? What else should I Installed? And how to install them?

Thanks,

Zhen



2016-12-15 10:39 GMT+08:00 Dan Burkert <danburkert@apache.org>:
Hi Zhen,

The issue with homebrew krb5 is that it's contained in the dupes tap.  Run `brew tap homebrew/dupes` and then `brew install krb5` should succeed.  I've submitted a change to the docs to call this out in the install instructions.  The compile issue may be that you do not have XCode installed - CLT is not sufficient.

- Dan

On Wed, Dec 14, 2016 at 6:19 PM, Alexey Serbin <aserbin@cloudera.com> wrote:
Hi Zhen,

What does the 'xcodeselect -p' command output on your mac?

BTW, regarding homebrew and krb5: if you happen to use MacPorts, you can install port named 'kerberos5'.  But 'krb5' should work for homebrew, though.


Best regards,

Alexey

On Wed, Dec 14, 2016 at 1:22 AM, Zhen Zhang <zhquake@gmail.com> wrote:
Hi Todd,

Thanks for your help, the error message seems same, but before build kudu, I've already installed xcode using command "xcode-select --install", don't know why still occured this error. Yes, I followed this docs(http://kudu.apache.org/docs/installation.html#osx_from_source) to build.

By the way, the command "brew install krb5" failed on my mac, it said:
➜  kudu git:(github)  brew install krb5
Updating Homebrew...
Error: No available formula with the name "krb5"
==> Searching for similarly named formulae...
Error: No similarly named formulae found.
==> Searching taps...
Error: No formulae found in taps

Thanks,
Zhen

2016-12-14 16:37 GMT+08:00 Todd Lipcon <todd@cloudera.com>:
Hi Zhen,

I'm not a Mac user, so just taking my best guess here. https://issues.apache.org/jira/browse/KUDU-1530 mentions the same error message as being indicative that the xcode command line tools aren't properly installed. The patch for this issue (http://gerrit.cloudera.org:8080/3653) updated the OSX install docs. Are you following those docs? ( http://kudu.apache.org/docs/installation.html#osx_from_source )

If that doesn't help, hopefully someone who uses OSX to build Kudu will respond later today from PST time zone.

-Todd


On Wed, Dec 14, 2016 at 12:56 PM, Zhen Zhang <zhquake@gmail.com> wrote:
Hi Todd,

My os version is 10.12.1, I already installed xcode, and I can find the stdio.h file under /usr/include

My gcc version is:

➜  kudu git:(github) gcc -v

Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/usr/include/c++/4.2.1

Apple LLVM version 8.0.0 (clang-800.0.42.1)

Target: x86_64-apple-darwin16.1.0

Thread model: posix

InstalledDir: /Library/Developer/CommandLineTools/usr/bin




2016-12-14 13:43 GMT+08:00 Todd Lipcon <todd@cloudera.com>:

Hi Zhen,

Can you share which version of osx you are running? Also have you installed the osx development tools (xcode etc)?

Todd


On Dec 14, 2016 12:33 PM, "Zhen Zhang" <zhquake@gmail.com> wrote:
hi all,

I tried to build kudu from source on my mac and get the following error after run "thirdparty/build-if-necessary.sh"

clang: warning: no such sysroot directory: '-mmacosx-version-min=10.5'

/Users/zhenzhang/projects/kudu/thirdparty/src/llvm-3.9.0.src/projects/compiler-rt/lib/builtins/eprintf.c:14:10: fatal error: 'stdio.h' file not found

#include <stdio.h>


Only llvm in the thirdparty failed with such message. All others can build success, do you know how to fix this?


Thanks,

zhen





--
Todd Lipcon
Software Engineer, Cloudera