kudu-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Wolf <nickwo...@gmail.com>
Subject Re: in clause issue
Date Thu, 28 Jan 2016 22:31:03 GMT
Thanks David. I got it solved. When i compiled the backend it has generated
a file called "libExec.a". Do you know how to deploy this in a working
environment? I tried to look for this file in list of installed files from
parcels but i couldn't find.

On Wed, Jan 27, 2016 at 6:54 PM, David Alves <davidralves@gmail.com> wrote:

> Hi Nick
>
>   The problem you're getting is that impala requires the kudu client
> libraries. If kudu is in a sibling directory to impala named "kudu" I think
> the easiest way is to run "DEST_DIR=kudu-cli-export make install" on the
> kudu source root and then retry the impala build. If this is not your
> directory layout or you want to use some other directory to install the
> kudu libs you can set KUDU_HOME and KUDU_CLIENT_ROOT respectively.
>   Btw, these vars are set by impala-config.sh if that helps.
>
> Best
> David
>
> On Wed, Jan 27, 2016 at 3:44 PM, Nick Wolf <nickwolf7@gmail.com> wrote:
>
>> Thanks David. I got stuck with following error building the impala-kudu
>> source. Any help here is appreciated.
>>
>> CMake Error at CMakeLists.txt:198 (find_package):
>>   Could not find a package configuration file provided by "kuduClient"
>> with
>>   any of the following names:
>>
>>     kuduClientConfig.cmake
>>     kuduclient-config.cmake
>>
>>   Add the installation prefix of "kuduClient" to CMAKE_PREFIX_PATH or set
>>   "kuduClient_DIR" to a directory containing one of the above files.  If
>>   "kuduClient" provides a separate development package or SDK, be sure it
>> has
>>   been installed.
>>
>>
>> On Tue, Jan 26, 2016 at 5:05 PM, David Alves <davidralves@gmail.com>
>> wrote:
>>
>>> Hi Nick
>>>
>>>   Hum, we haven't updated the upstream mirror in a while (things are
>>> kind of in flux with the impala trunk merge).
>>>   I've just updated it. If you pull from
>>> https://github.com/cloudera/impala-kudu/tree/feature/kudu  you should
>>> now see that and other fixes.
>>>
>>> Best
>>> David
>>>
>>> On Tue, Jan 26, 2016 at 4:55 PM, Nick Wolf <nickwolf7@gmail.com> wrote:
>>>
>>>> I've noticed the issue is marked as fixed
>>>> https://issues.cloudera.org/browse/IMPALA-2740
>>>>
>>>> Can someone tell me which branch or trunk is this issue fixed? I've
>>>> searched in Impala, Impala-kudu and Kudu but i couldn't find any commit on
>>>> this SHA.
>>>>
>>>>
>>>>
>>>>
>>>
>>
>

Mime
View raw message