kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From granthe...@apache.org
Subject kudu git commit: [Java] Upgrade dependencies
Date Wed, 12 Dec 2018 22:13:19 GMT
Repository: kudu
Updated Branches:
  refs/heads/master 77eadefa1 -> 93211b34c


[Java] Upgrade dependencies

Upgrades the Java dependencies and Gradle versions.

This patch also has a few build fixes to support
Gradle 5.0.

Minor version upgrades:
- ClojureToolsCli 0.3.5 -> 0.4.1
- Guava 26.0-android -> 27.0-android
- Mockito 2.22.0 -> 2.23.4

Maintenance version upgrades:
- Errorprone 2.3.1 -> 2.3.2
- Hive 2.3.3 -> 2.3.4

Gradle upgrades:
- Gradle 4.10.2 -> 5.0
- gradle-avro-plugin 0.15.1 -> 0.16.0
- shadow 2.0.4 -> 4.0.2
- protobuf-gradle-plugin 0.8.6 -> 0.8.7
- nebula-clojure-plugin 6.0.2 -> 7.0.1
- spotbugs-gradle-plugin 1.6.4 -> 1.6.5

Change-Id: Ic09189d7fee7f2348718375083c32fa7b00ec5c0
Reviewed-on: http://gerrit.cloudera.org:8080/12076
Tested-by: Kudu Jenkins
Reviewed-by: Adar Dembo <adar@cloudera.com>


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/93211b34
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/93211b34
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/93211b34

Branch: refs/heads/master
Commit: 93211b34c6864e8755964d7ba4658ae5476571a4
Parents: 77eadef
Author: Grant Henke <granthenke@apache.org>
Authored: Wed Dec 12 14:02:41 2018 -0600
Committer: Grant Henke <granthenke@apache.org>
Committed: Wed Dec 12 22:12:45 2018 +0000

----------------------------------------------------------------------
 java/buildSrc/build.gradle                    | 15 ++++++++++-----
 java/gradle/compile.gradle                    | 17 ++++-------------
 java/gradle/dependencies.gradle               | 12 ++++++------
 java/gradle/docs.gradle                       |  2 +-
 java/gradle/shadow.gradle                     |  3 ++-
 java/gradle/wrapper/gradle-wrapper.properties |  2 +-
 java/gradlew                                  |  4 ++--
 7 files changed, 26 insertions(+), 29 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/93211b34/java/buildSrc/build.gradle
----------------------------------------------------------------------
diff --git a/java/buildSrc/build.gradle b/java/buildSrc/build.gradle
index f02633f..9fd924e 100644
--- a/java/buildSrc/build.gradle
+++ b/java/buildSrc/build.gradle
@@ -28,15 +28,20 @@ repositories {
 // Manage plugin dependencies since the plugin block can't be used in included build scripts
yet.
 // For more details see: https://docs.gradle.org/current/userguide/plugins.html#plugins_dsl_limitations
 dependencies {
-  compile "com.commercehub.gradle.plugin:gradle-avro-plugin:0.15.1"
+  compile "com.commercehub.gradle.plugin:gradle-avro-plugin:0.16.0"
   compile "com.github.ben-manes:gradle-versions-plugin:0.20.0"
-  compile "com.github.jengelman.gradle.plugins:shadow:2.0.4"
-  compile "com.google.protobuf:protobuf-gradle-plugin:0.8.6"
-  compile "com.netflix.nebula:nebula-clojure-plugin:6.0.2"
-  compile "gradle.plugin.com.github.spotbugs:spotbugs-gradle-plugin:1.6.4"
+  compile "com.github.jengelman.gradle.plugins:shadow:4.0.2"
+  compile "com.google.protobuf:protobuf-gradle-plugin:0.8.7"
+  compile "com.netflix.nebula:nebula-clojure-plugin:7.0.1"
+  compile "gradle.plugin.com.github.spotbugs:spotbugs-gradle-plugin:1.6.5"
   compile "io.spring.gradle:propdeps-plugin:0.0.9.RELEASE"
   compile "net.ltgt.gradle:gradle-errorprone-plugin:0.0.16"
   compile "ru.vyarus:gradle-animalsniffer-plugin:1.4.6"
   compile 'com.google.code.gson:gson:2.8.5'
   compile "cz.alenkacz:gradle-scalafmt:1.7.0"
 }
+
+// Compiler configuration
+tasks.withType(GroovyCompile) {
+  options.compilerArgs << '-proc:none' // Ignore leaked annotation processors on the
compile classpath.
+}

http://git-wip-us.apache.org/repos/asf/kudu/blob/93211b34/java/gradle/compile.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/compile.gradle b/java/gradle/compile.gradle
index 87aea09..896b24a 100644
--- a/java/gradle/compile.gradle
+++ b/java/gradle/compile.gradle
@@ -17,8 +17,8 @@
 
 // This file contains common compiler configurations.
 
-// Java Configuration
-tasks.withType(JavaCompile) {
+// JVM based compiler configuration
+tasks.withType(AbstractCompile) {
   sourceCompatibility = "1.$javaCompatibility"
   targetCompatibility = "1.$javaCompatibility"
   // --release is the recommended way to select the target release, but it's only supported
in
@@ -33,17 +33,8 @@ tasks.withType(JavaCompile) {
   options.compilerArgs << '-proc:none' // Ignore leaked annotation processors on the
compile classpath.
 }
 
-// Scala configuration
+// Scala compiler configuration
 tasks.withType(ScalaCompile) {
-  sourceCompatibility = "1.$javaCompatibility"
-  targetCompatibility = "1.$javaCompatibility"
-  // --release is the recommended way to select the target release, but it's only supported
in
-  // Java 9+ so we also set -source and -target via `sourceCompatibility` and `targetCompatibility`.
-  // If/when Gradle supports `--release` natively (https://github.com/gradle/gradle/issues/2510),
-  // we should switch to that.
-  if (JavaVersion.current().isJava9Compatible()) {
-    options.compilerArgs << "--release" << "$javaCompatibility"
-  }
   scalaCompileOptions.encoding = encoding // make sure the encoding is defined by the project
and not the system default.
   scalaCompileOptions.additionalParameters = [
       // Emit warning and location for usages of features that should be imported explicitly.
@@ -51,4 +42,4 @@ tasks.withType(ScalaCompile) {
       // Emit various static analysis warnings.
       "-Xlint"
   ]
-}
+}
\ No newline at end of file

http://git-wip-us.apache.org/repos/asf/kudu/blob/93211b34/java/gradle/dependencies.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/dependencies.gradle b/java/gradle/dependencies.gradle
index 71cfe16..4254663 100755
--- a/java/gradle/dependencies.gradle
+++ b/java/gradle/dependencies.gradle
@@ -28,22 +28,22 @@ versions += [
     async          : "1.4.1",
     avro           : "1.8.2",
     clojure        : "1.9.0",
-    clojureToolsCli: "0.3.5",
+    clojureToolsCli: "0.4.1",
     commonsIo      : "2.6",
-    errorprone     : "2.3.1",
+    errorprone     : "2.3.2",
     flume          : "1.8.0",
-    gradle         : "4.10.2",
+    gradle         : "5.0",
     // We use the android version instead of the jre version
     // to maintain Java 1.7 compatibility.
-    guava          : "26.0-android",
+    guava          : "27.0-android",
     hadoop         : "3.1.1",
     hamcrest       : "1.3",
-    hive           : "2.3.3",
+    hive           : "2.3.4",
     jepsen         : "0.1.5",
     jsr305         : "3.0.2",
     junit          : "4.12",
     log4j          : "1.2.17",
-    mockito        : "2.22.0",
+    mockito        : "2.23.4",
     murmur         : "1.0.0",
     netty          : "3.10.6.Final",
     parquet        : "1.10.0",

http://git-wip-us.apache.org/repos/asf/kudu/blob/93211b34/java/gradle/docs.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/docs.gradle b/java/gradle/docs.gradle
index 82060b1..d9ef7cf 100644
--- a/java/gradle/docs.gradle
+++ b/java/gradle/docs.gradle
@@ -22,7 +22,7 @@ configurations {
 }
 
 dependencies {
-  doclet "org.apache.yetus:audience-annotations:0.7.0"
+  doclet libs.yetusAnnotations
 }
 
 // Javadoc Configuration

http://git-wip-us.apache.org/repos/asf/kudu/blob/93211b34/java/gradle/shadow.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/shadow.gradle b/java/gradle/shadow.gradle
index 4a5d8ca..f89b98d 100644
--- a/java/gradle/shadow.gradle
+++ b/java/gradle/shadow.gradle
@@ -22,7 +22,8 @@ import org.gradle.api.internal.artifacts.publish.ArchivePublishArtifact
 
 apply plugin: "com.github.johnrengelman.shadow"
 
-tasks.remove(knows)  // Remove "easter egg" knows task.
+knows.enabled = false // Disable the "easter egg" knows task.
+knows.group = "" // Hide the "easter egg" knows task.
 shadowJar.group = "" // Hide shadowJar task since it's used by the default build.
 
 // Configure a shaded jar to replace the default jar

http://git-wip-us.apache.org/repos/asf/kudu/blob/93211b34/java/gradle/wrapper/gradle-wrapper.properties
----------------------------------------------------------------------
diff --git a/java/gradle/wrapper/gradle-wrapper.properties b/java/gradle/wrapper/gradle-wrapper.properties
index 507a527..3a8f801 100644
--- a/java/gradle/wrapper/gradle-wrapper.properties
+++ b/java/gradle/wrapper/gradle-wrapper.properties
@@ -14,6 +14,6 @@
 # limitations under the License.
 distributionBase=GRADLE_USER_HOME
 distributionPath=wrapper/dists
-distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.2-all.zip
+distributionUrl=https\://services.gradle.org/distributions/gradle-5.0-all.zip
 zipStoreBase=GRADLE_USER_HOME
 zipStorePath=wrapper/dists

http://git-wip-us.apache.org/repos/asf/kudu/blob/93211b34/java/gradlew
----------------------------------------------------------------------
diff --git a/java/gradlew b/java/gradlew
index 47787ba..f3276ba 100755
--- a/java/gradlew
+++ b/java/gradlew
@@ -42,7 +42,7 @@ APP_NAME="Gradle"
 APP_BASE_NAME=`basename "$0"`
 
 # Add default JVM options here. You can also use JAVA_OPTS and GRADLE_OPTS to pass JVM options
to this script.
-DEFAULT_JVM_OPTS=""
+DEFAULT_JVM_OPTS='"-Xmx64m"'
 
 # Use the maximum available, or set MAX_FD != -1 to use that value.
 MAX_FD="maximum"
@@ -82,7 +82,7 @@ esac
 # Loop in case we encounter an error.
 for attempt in 1 2 3; do
   if [ ! -e $APP_HOME/gradle/wrapper/gradle-wrapper.jar ]; then
-    if ! curl -s -S --retry 3 -L -o "$APP_HOME/gradle/wrapper/gradle-wrapper.jar" "https://raw.githubusercontent.com/gradle/gradle/v4.10.2/gradle/wrapper/gradle-wrapper.jar";
then
+    if ! curl -s -S --retry 3 -L -o "$APP_HOME/gradle/wrapper/gradle-wrapper.jar" "https://raw.githubusercontent.com/gradle/gradle/v5.0.0/gradle/wrapper/gradle-wrapper.jar";
then
       rm -f "$APP_HOME/gradle/wrapper/gradle-wrapper.jar"
       # Pause for a bit before looping in case the server throttled us.
       sleep 5


Mime
View raw message