kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From granthe...@apache.org
Subject kudu git commit: [java] Downgrade errorprone to 2.3.1
Date Fri, 14 Dec 2018 04:18:10 GMT
Repository: kudu
Updated Branches:
  refs/heads/master 5395dce78 -> 90096493d


[java] Downgrade errorprone to 2.3.1

Errorprone 2.3.2 can cause build issues on older
jdks. This patch downgrades it to 2.3.1 until the issue
is resolved.

Change-Id: I6162722ae2a37ebb8398cc7c6fdf4246eb2a18c5
Reviewed-on: http://gerrit.cloudera.org:8080/12080
Reviewed-by: Adar Dembo <adar@cloudera.com>
Tested-by: Kudu Jenkins


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/90096493
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/90096493
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/90096493

Branch: refs/heads/master
Commit: 90096493df3c5af68fa85585819e9f45e8af3159
Parents: 5395dce
Author: Grant Henke <granthenke@apache.org>
Authored: Thu Dec 13 17:25:06 2018 -0600
Committer: Grant Henke <granthenke@apache.org>
Committed: Fri Dec 14 00:34:58 2018 +0000

----------------------------------------------------------------------
 java/gradle/dependencies.gradle | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/90096493/java/gradle/dependencies.gradle
----------------------------------------------------------------------
diff --git a/java/gradle/dependencies.gradle b/java/gradle/dependencies.gradle
index 4254663..19d8e45 100755
--- a/java/gradle/dependencies.gradle
+++ b/java/gradle/dependencies.gradle
@@ -30,7 +30,9 @@ versions += [
     clojure        : "1.9.0",
     clojureToolsCli: "0.4.1",
     commonsIo      : "2.6",
-    errorprone     : "2.3.2",
+    // errorprone 2.3.2+ has an issue on older JDKs see
+    // https://github.com/google/error-prone/issues/1140
+    errorprone     : "2.3.1",
     flume          : "1.8.0",
     gradle         : "5.0",
     // We use the android version instead of the jre version


Mime
View raw message