kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mpe...@apache.org
Subject kudu git commit: docs: Update to more recent jekyll
Date Wed, 29 Nov 2017 08:23:18 GMT
Repository: kudu
Updated Branches:
  refs/heads/master 5d8dc02b3 -> 5c87c22be


docs: Update to more recent jekyll

Since it's not possible for docs generation to work on both macOS and
RHEL 6, let's drop RHEL 6 and move to RHEL 7 as the minimum on Linux to
build the docs.

This also allows us to upgrade the version of yajl-ruby, for which there
is a CVE on versions <= 1.2.2 and 1.3.0.
See https://nvd.nist.gov/vuln/detail/CVE-2017-16516

Change-Id: If3733d1daec263a3ffd1bcd6976d8cd4ba11ddeb
Reviewed-on: http://gerrit.cloudera.org:8080/8678
Reviewed-by: Mike Percy <mpercy@apache.org>
Tested-by: Mike Percy <mpercy@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/5c87c22b
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/5c87c22b
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/5c87c22b

Branch: refs/heads/master
Commit: 5c87c22be1559e2670624ea8cdf7e2f0d065855e
Parents: 5d8dc02
Author: Mike Percy <mpercy@cloudera.com>
Authored: Tue Nov 28 23:11:53 2017 -0800
Committer: Mike Percy <mpercy@apache.org>
Committed: Wed Nov 29 08:23:07 2017 +0000

----------------------------------------------------------------------
 docs/support/scripts/Gemfile      |  14 +++--
 docs/support/scripts/Gemfile.lock | 111 +++++++++++++++++----------------
 docs/support/scripts/make_site.sh |   1 +
 3 files changed, 67 insertions(+), 59 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/5c87c22b/docs/support/scripts/Gemfile
----------------------------------------------------------------------
diff --git a/docs/support/scripts/Gemfile b/docs/support/scripts/Gemfile
index 2948545..0ac227b 100644
--- a/docs/support/scripts/Gemfile
+++ b/docs/support/scripts/Gemfile
@@ -15,16 +15,20 @@
 # specific language governing permissions and limitations
 # under the License.
 
+# We need to use versions that can run on CentOS 7, which ships Ruby 2.0.0.
+ruby '>= 2.0.0'
+
 source 'https://rubygems.org'
 
-# We need to use versions that can run on CentOS 6, which ships Ruby 1.8.7.
 gem 'thread_safe'
-gem 'redcarpet', '~> 2.3.0'
-gem 'jekyll', '~> 1.5.1'
-gem 'therubyracer' # V8 runtime installer for Jekyll
-gem 'ref', '~> 1.0'
+gem 'redcarpet'
+gem 'jekyll'
+gem 'therubyracer' # V8 runtime installer for Jekyll.
+gem 'ref'
 gem 'json'
 gem 'rdoc'
+gem 'yajl-ruby', '>= 1.3.1' # Due to CVE-2017-16516.
+gem 'libv8', '>= 3.16.14.14' # Needed for macOS.
 
 gem 'asciidoctor'
 gem 'tilt'

http://git-wip-us.apache.org/repos/asf/kudu/blob/5c87c22b/docs/support/scripts/Gemfile.lock
----------------------------------------------------------------------
diff --git a/docs/support/scripts/Gemfile.lock b/docs/support/scripts/Gemfile.lock
index 30b3db7..82bd84a 100644
--- a/docs/support/scripts/Gemfile.lock
+++ b/docs/support/scripts/Gemfile.lock
@@ -1,73 +1,76 @@
 GEM
   remote: https://rubygems.org/
   specs:
-    asciidoctor (1.5.3)
-    blankslate (2.1.2.4)
-    classifier (1.3.4)
-      fast-stemmer (>= 1.0.0)
-    colorator (0.1)
-    commander (4.1.6)
-      highline (~> 1.6.11)
-    fast-stemmer (1.0.2)
-    ffi (1.9.10)
-    highline (1.6.21)
-    jekyll (1.5.1)
-      classifier (~> 1.3)
-      colorator (~> 0.1)
-      commander (~> 4.1.3)
-      liquid (~> 2.5.5)
-      listen (~> 1.3)
-      maruku (= 0.7.0)
-      pygments.rb (~> 0.5.0)
-      redcarpet (~> 2.3.0)
+    addressable (2.5.2)
+      public_suffix (>= 2.0.2, < 4.0)
+    asciidoctor (1.5.6.1)
+    colorator (1.1.0)
+    ffi (1.9.18)
+    forwardable-extended (2.6.0)
+    jekyll (3.4.5)
+      addressable (~> 2.4)
+      colorator (~> 1.0)
+      jekyll-sass-converter (~> 1.0)
+      jekyll-watch (~> 1.1)
+      kramdown (~> 1.3)
+      liquid (~> 3.0)
+      mercenary (~> 0.3.3)
+      pathutil (~> 0.9)
+      rouge (~> 1.7)
       safe_yaml (~> 1.0)
-      toml (~> 0.1.0)
-    json (1.8.5)
-    libv8 (3.16.14.14)
-    liquid (2.5.5)
-    listen (1.3.1)
-      rb-fsevent (>= 0.9.3)
-      rb-inotify (>= 0.9)
-      rb-kqueue (>= 0.2)
-    maruku (0.7.0)
-    parslet (1.5.0)
-      blankslate (~> 2.0)
-    posix-spawn (0.3.11)
-    pygments.rb (0.5.4)
-      posix-spawn (~> 0.3.6)
-      yajl-ruby (~> 1.1.0)
-    rb-fsevent (0.9.6)
-    rb-inotify (0.9.5)
-      ffi (>= 0.5.0)
-    rb-kqueue (0.2.4)
-      ffi (>= 0.5.0)
-    rdoc (4.2.0)
-      json (~> 1.4)
-    redcarpet (2.3.0)
-    ref (1.0.5)
+    jekyll-sass-converter (1.5.0)
+      sass (~> 3.4)
+    jekyll-watch (1.5.0)
+      listen (~> 3.0, < 3.1)
+    json (2.1.0)
+    kramdown (1.16.1)
+    libv8 (3.16.14.19)
+    liquid (3.0.6)
+    listen (3.0.8)
+      rb-fsevent (~> 0.9, >= 0.9.4)
+      rb-inotify (~> 0.9, >= 0.9.7)
+    mercenary (0.3.6)
+    pathutil (0.16.0)
+      forwardable-extended (~> 2.6)
+    public_suffix (2.0.5)
+    rb-fsevent (0.10.2)
+    rb-inotify (0.9.10)
+      ffi (>= 0.5.0, < 2)
+    rdoc (4.3.0)
+    redcarpet (3.4.0)
+    ref (2.0.0)
+    rouge (1.11.1)
     safe_yaml (1.0.4)
-    therubyracer (0.12.2)
-      libv8 (~> 3.16.14.0)
+    sass (3.5.3)
+      sass-listen (~> 4.0.0)
+    sass-listen (4.0.0)
+      rb-fsevent (~> 0.9, >= 0.9.4)
+      rb-inotify (~> 0.9, >= 0.9.7)
+    therubyracer (0.12.3)
+      libv8 (~> 3.16.14.15)
       ref
-    thread_safe (0.3.5)
-    tilt (2.0.1)
-    toml (0.1.2)
-      parslet (~> 1.5.0)
-    yajl-ruby (1.1.0)
+    thread_safe (0.3.6)
+    tilt (2.0.8)
+    yajl-ruby (1.3.1)
 
 PLATFORMS
   ruby
 
 DEPENDENCIES
   asciidoctor
-  jekyll (~> 1.5.1)
+  jekyll
   json
+  libv8 (>= 3.16.14.14)
   rdoc
-  redcarpet (~> 2.3.0)
-  ref (~> 1.0)
+  redcarpet
+  ref
   therubyracer
   thread_safe
   tilt
+  yajl-ruby (>= 1.3.1)
+
+RUBY VERSION
+   ruby 2.0.0p648
 
 BUNDLED WITH
-   1.10.6
+   1.16.0

http://git-wip-us.apache.org/repos/asf/kudu/blob/5c87c22b/docs/support/scripts/make_site.sh
----------------------------------------------------------------------
diff --git a/docs/support/scripts/make_site.sh b/docs/support/scripts/make_site.sh
index d12269a..8d7cefa 100755
--- a/docs/support/scripts/make_site.sh
+++ b/docs/support/scripts/make_site.sh
@@ -140,6 +140,7 @@ cd "$SITE_OUTPUT_DIR"
 SITE_ARCHIVE="$SITE_OUTPUT_DIR/website_archive.zip"
 zip -rq "$SITE_ARCHIVE" $SITE_SUBDIRS
 
+set +x
 echo "Generated web site at $SITE_OUTPUT_DIR"
 echo "Docs zip generated at $SITE_ARCHIVE"
 echo "To view live site locally, run: (cd $SITE_OUTPUT_DIR && ./site_tool jekyll
serve)"


Mime
View raw message