kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jdcry...@apache.org
Subject kudu git commit: [build] Fix Python build failures on RHEL 6
Date Fri, 04 Aug 2017 20:44:37 GMT
Repository: kudu
Updated Branches:
  refs/heads/master b04490b86 -> d0acb5551


[build] Fix Python build failures on RHEL 6

Internal build machines running RHEL 6 started failing recently on something
that looks a lot like: https://github.com/pypa/pip/issues/3045

But we already have the fix in. This patch works around the problem by upgrading
setuptools separately which somehow works.

Change-Id: I05ddecc4f903607f1131015277c1f36f2d766acb
Reviewed-on: http://gerrit.cloudera.org:8080/7589
Reviewed-by: David Ribeiro Alves <davidralves@gmail.com>
Tested-by: Jean-Daniel Cryans <jdcryans@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/d0acb555
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/d0acb555
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/d0acb555

Branch: refs/heads/master
Commit: d0acb55510c0552605953e07740f46d6be66c9c1
Parents: b04490b
Author: Jean-Daniel Cryans <jdcryans@apache.org>
Authored: Fri Aug 4 11:23:55 2017 -0700
Committer: Jean-Daniel Cryans <jdcryans@apache.org>
Committed: Fri Aug 4 20:29:38 2017 +0000

----------------------------------------------------------------------
 build-support/jenkins/build-and-test.sh | 5 +++++
 python/requirements.txt                 | 1 -
 2 files changed, 5 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/d0acb555/build-support/jenkins/build-and-test.sh
----------------------------------------------------------------------
diff --git a/build-support/jenkins/build-and-test.sh b/build-support/jenkins/build-and-test.sh
index a2ba47b..d2e9a94 100755
--- a/build-support/jenkins/build-and-test.sh
+++ b/build-support/jenkins/build-and-test.sh
@@ -391,6 +391,9 @@ if [ "$BUILD_PYTHON" == "1" ]; then
   virtualenv $KUDU_BUILD/py_env
   source $KUDU_BUILD/py_env/bin/activate
   pip install --upgrade pip
+  # On RHEL 6, keeping setuptools in requirements.txt fails as of setuptools 36.2.7.
+  # Strangely, it does work when extracted like this.
+  pip install --disable-pip-version-check --upgrade 'setuptools >= 0.8'
   CC=$CLANG CXX=$CLANG++ pip install --disable-pip-version-check -r requirements.txt
 
   # Delete old Cython extensions to force them to be rebuilt.
@@ -425,6 +428,8 @@ if [ "$BUILD_PYTHON3" == "1" ]; then
   virtualenv -p python3 $KUDU_BUILD/py_env
   source $KUDU_BUILD/py_env/bin/activate
   pip install --upgrade pip
+  # See the comment in the BUILD_PYTHON section above for why we need this line.
+  pip install --disable-pip-version-check --upgrade 'setuptools >= 0.8'
   CC=$CLANG CXX=$CLANG++ pip install --disable-pip-version-check -r requirements.txt
 
   # Delete old Cython extensions to force them to be rebuilt.

http://git-wip-us.apache.org/repos/asf/kudu/blob/d0acb555/python/requirements.txt
----------------------------------------------------------------------
diff --git a/python/requirements.txt b/python/requirements.txt
index 72d6c68..9df81cd 100644
--- a/python/requirements.txt
+++ b/python/requirements.txt
@@ -1,6 +1,5 @@
 pytest
 cython >= 0.21
-setuptools >= 0.8
 six
 unittest2
 pytz


Mime
View raw message