kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From a...@apache.org
Subject [2/2] kudu git commit: thirdparty: upgrade to python 2.7.13
Date Tue, 21 Feb 2017 22:30:49 GMT
thirdparty: upgrade to python 2.7.13

On very rare occasion, the Python build fails with an error like this:

  Parser/acceler.o: file not recognized: File truncated
  collect2: error: ld returned 1 exit status

It's not reproducible, and it seems to only happen when make is run with a
strange -j and the machine placed under load. The failure seems like
this [1] Python issue, a fix for which was backported to 2.7.12. So let's
take the opportunity to upgrade to the latest Python 2.7 release.

I tested this by rebuilding the thirdparty tree on a CentOS 6.6 box.

1. https://bugs.python.org/issue22359

Change-Id: I309bc6a0ef7d919d3610ed322d76953dfb090426
Reviewed-on: http://gerrit.cloudera.org:8080/6093
Tested-by: Adar Dembo <adar@cloudera.com>
Reviewed-by: Dan Burkert <danburkert@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/91a35784
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/91a35784
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/91a35784

Branch: refs/heads/master
Commit: 91a35784efa1bf3a294ae3da483d89f7ffe1d70b
Parents: a099e85
Author: Adar Dembo <adar@cloudera.com>
Authored: Tue Feb 21 01:15:01 2017 -0800
Committer: Adar Dembo <adar@cloudera.com>
Committed: Tue Feb 21 22:30:28 2017 +0000

----------------------------------------------------------------------
 thirdparty/vars.sh | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/91a35784/thirdparty/vars.sh
----------------------------------------------------------------------
diff --git a/thirdparty/vars.sh b/thirdparty/vars.sh
index d653afd..6e833e0 100644
--- a/thirdparty/vars.sh
+++ b/thirdparty/vars.sh
@@ -146,7 +146,7 @@ LLVM_SOURCE=$TP_SOURCE_DIR/$LLVM_NAME
 
 # Python 2.7 is required to build LLVM 3.6+. It is only built and installed if
 # the system Python version is not 2.7.
-PYTHON_VERSION=2.7.10
+PYTHON_VERSION=2.7.13
 PYTHON_NAME=python-$PYTHON_VERSION
 PYTHON_SOURCE=$TP_SOURCE_DIR/$PYTHON_NAME
 


Mime
View raw message