kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ale...@apache.org
Subject [1/2] kudu git commit: [OpenSSL] require at least 1.0.0 version
Date Tue, 08 Nov 2016 00:14:17 GMT
Repository: kudu
Updated Branches:
  refs/heads/master e85e44c78 -> ae07d0dc4


[OpenSSL] require at least 1.0.0 version

To build the project, it's necessary to have OpenSSL version 1.0.0
or higher: we are using some features which have been introduced
in version 1.0.0 of the OpenSSL framework.

Change-Id: Ie1b60f730f3d6e5645a310fb40df39d04367e688
Reviewed-on: http://gerrit.cloudera.org:8080/4937
Tested-by: Kudu Jenkins
Reviewed-by: Todd Lipcon <todd@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/kudu/commit/fd34f453
Tree: http://git-wip-us.apache.org/repos/asf/kudu/tree/fd34f453
Diff: http://git-wip-us.apache.org/repos/asf/kudu/diff/fd34f453

Branch: refs/heads/master
Commit: fd34f45326d51df8338c0bcf79398a6e0167a19e
Parents: e85e44c
Author: Alexey Serbin <aserbin@cloudera.com>
Authored: Fri Nov 4 19:13:36 2016 -0700
Committer: Todd Lipcon <todd@apache.org>
Committed: Mon Nov 7 22:48:53 2016 +0000

----------------------------------------------------------------------
 CMakeLists.txt | 15 ++++++++++++++-
 1 file changed, 14 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/kudu/blob/fd34f453/CMakeLists.txt
----------------------------------------------------------------------
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92cd46f..08d936d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -830,7 +830,20 @@ include_directories(SYSTEM ${SQUEASEL_INCLUDE_DIR})
 ADD_THIRDPARTY_LIB(squeasel
   STATIC_LIB "${SQUEASEL_STATIC_LIB}")
 
-find_package(OpenSSL REQUIRED)
+## OpenSSL
+##
+## Version 1.0.0 or higher is required because we are using the following
+## features introduced started OpenSSL 1.0.0:
+##   * CRYPTO_THREADID and associated functions
+##   * The new breed of functions to work with the X509_EXTENSION stack
+##
+## If having multiple OpenSSL libraries installed on the system,
+## use the OPENSSL_ROOT_DIR cmake flag to specify where to look for the proper
+## version of the OpenSSL framework/library, e.g.
+##
+##   cmake -DOPENSSL_ROOT_DIR=/usr/local/opt/openssl ...
+##
+find_package(OpenSSL 1.0.0 REQUIRED)
 include_directories(${OPENSSL_INCLUDE_DIR})
 ADD_THIRDPARTY_LIB(openssl_ssl
   SHARED_LIB "${OPENSSL_SSL_LIBRARY}")


Mime
View raw message