kudu-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mpe...@apache.org
Subject [2/6] incubator-kudu git commit: docs: asciidoctor gem not needed, zlib headers needed
Date Sun, 15 May 2016 20:38:43 GMT
docs: asciidoctor gem not needed, zlib headers needed

Since we now have scripts that use bundler, the asciidoctor gem no
longer needs to be installed manually. However, we need zlib headers for
nokogiri, which is a dependency of some of the gems

Change-Id: Ie2ffa1b7ccdb88421f4e81287765c7ab09cec771
Reviewed-on: http://gerrit.cloudera.org:8080/3060
Tested-by: Kudu Jenkins
Reviewed-by: Misty Stanley-Jones <misty@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/incubator-kudu/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-kudu/commit/02d9bd44
Tree: http://git-wip-us.apache.org/repos/asf/incubator-kudu/tree/02d9bd44
Diff: http://git-wip-us.apache.org/repos/asf/incubator-kudu/diff/02d9bd44

Branch: refs/heads/master
Commit: 02d9bd44af2af50833a299f2607ca1d58078afc1
Parents: b8a1970
Author: Mike Percy <mpercy@apache.org>
Authored: Mon Apr 25 16:02:17 2016 -0700
Committer: Misty Stanley-Jones <misty@apache.org>
Committed: Fri May 13 20:19:53 2016 +0000

----------------------------------------------------------------------
 docs/installation.adoc | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-kudu/blob/02d9bd44/docs/installation.adoc
----------------------------------------------------------------------
diff --git a/docs/installation.adoc b/docs/installation.adoc
index 1738a7a..f70cded 100644
--- a/docs/installation.adoc
+++ b/docs/installation.adoc
@@ -230,11 +230,10 @@ $ sudo yum install -y scl-utils ${DTLS_RPM}
 $ sudo yum install -y devtoolset-3-toolchain
 ----
 
-. Optional: Install the gem and ruby-devel packages, and the `asciidoctor` gem if you plan
to build documentation.
+. Optional: Install some additional packages, including ruby, if you plan to build documentation.
 +
 ----
-$ sudo yum install gem ruby-devel
-$ sudo gem install asciidoctor
+$ sudo yum install gem ruby-devel zlib-devel
 ----
 
 . Clone the Git repository and change to the new `kudu` directory.
@@ -326,10 +325,10 @@ $ sudo apt-get install git autoconf automake libboost-thread-dev \
   libtool ntp patch pkg-config make rsync unzip vim-common gdb python
 ----
 
-. Optional: Install the `asciidoctor` gem and xsltproc if you plan to build documentation.
+. Optional: Install additional packages to build the documentation
 +
 ----
-$ sudo apt-get install asciidoctor xsltproc
+$ sudo apt-get install xsltproc zlib1g-dev
 ----
 
 . Clone the Git repository and change to the new `kudu` directory.


Mime
View raw message