knox-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <>
Subject [jira] [Commented] (KNOX-998) Rename class packages to org.apache.knox.gateway
Date Mon, 16 Oct 2017 17:07:01 GMT


ASF subversion and git services commented on KNOX-998:

Commit 7d0bff16e7128e5f2e10b54237cbc93f45932ffc in knox's branch refs/heads/KNOX-998-Package_Restructuring
from [~moresandeep]
[;h=7d0bff1 ]

KNOX-998 - package name refactoring

> Rename class packages to org.apache.knox.gateway
> ------------------------------------------------
>                 Key: KNOX-998
>                 URL:
>             Project: Apache Knox
>          Issue Type: Bug
>          Components: Server
>            Reporter: Sandeep More
>            Assignee: Sandeep More
>             Fix For: 0.14.0
> Update the package names in order to remove "hadoop" from the class packages throughout
 Apache Knox codebase. Currently, the package are some derivative of "org.apache.hadoop.gateway...".
The intent of this improvement is to make the class packages rooted at "org.apache.knox.gateway...".
We will have to determine what is needed to be backward compatible for any consumers that
have extended our existing classes however.

This message was sent by Atlassian JIRA

View raw message